GroupHeaderSection Border

2 posts, 0 answers
  1. Mark
    Mark avatar
    31 posts
    Member since:
    Jan 2012

    Posted 22 Feb Link to this post



    I have a double grouped report, which contains


    --> GroupHeaderSection





    This works fine and binds and displays the data correctly, but the borders for the outer group do not render correctly. I have added a couple of screen shots to illustrate. I've removed the text for confidentiality, but each "Blue" and "Grey" section contain a single line of text, and each white details section contains buttleted text. All text is rendered correctly.

    In the sample screenshots, Page1_Bottom  contains an extra border line at the bottom of the page, which I think is the closing border from the outermost Group. Looking at Page2_Top, the outer group Header section has a missing top border and I assume has been incorrectly rendered on the previous page.

    Our model is very complex and the reports heavily embedded in out wider application so it is very difficult to provide a sample project exhibiting the problem, so ay assistance you could be provide would be greatly appreciated.

    Many thanks,






  2. Nasko
    Nasko avatar
    909 posts

    Posted 24 Feb Link to this post

    Hello Mark,

    Set the borders in pixels to get more accurate results when rendering the report.
    In order to troubleshoot the described issue, please set the border width of all groups to 5px, solid, for all border sides.
    Then set different (contrasting) border colors for the parent group header/footer, child group header/footer, and the detail section.
    This should give you a clue how the borders are actually rendered and how to modify the report.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
Back to Top