GridView culture language on editmode

2 posts, 0 answers
  1. Stefania
    Stefania avatar
    107 posts
    Member since:
    May 2013

    Posted 13 Jul 2015 Link to this post

    Hi,

    I'm trying to change the culture number format as italian format on my gridview and keep the english language.

    If I copy and paste number without enter on edit mode, the cell is keeping the right format (for example 33.000,58)

    Otherwise if I'm entering on edit mode the cell lost the number format

     

    I uploaded the demo on support ticket

    Thank you

     

  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 14 Jul 2015 Link to this post

    Hello,

    Thank you for attaching a demo project in the support ticket.

    As to losing number format in edit mode, I would suggest you to try defining CellEditTemplate like so:
    <telerik:GridViewDataColumn  DataMemberBinding="{Binding Path=Value2}"DataFormatString="{}{0:N4}" Header="STRING FORMAT N4">
        <telerik:GridViewDataColumn.CellEditTemplate>
                <DataTemplate>
                        <TextBox Text="{Binding Value2, StringFormat=N4}" />
                </DataTemplate>
        </telerik:GridViewDataColumn.CellEditTemplate>
     </telerik:GridViewDataColumn>

    As a side note, we noticed you have set both this.Language and 
    myGrid.IsLocalizationLanguageRespected = false; 

    Please keep in mind you should configure one or the other since those settings contradict with one another.

    Regards,
    Dimitrina
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for WPF is Visual Studio 2017 Ready
Back to Top