Grid Paging controls disappear when page size set to more than record count.

4 posts, 1 answers
  1. JD.
    JD. avatar
    37 posts
    Member since:
    Aug 2012

    Posted 23 Sep 2011 Link to this post

    Hi

    I have a grid with has paging enabled.
    <telerik:RadGrid ID="RadGrid1" runat="server" AllowFilteringByColumn="True" 
        AllowPaging="True"  PageSize="5" ShowFooter="True" AllowSorting="True" AutoGenerateColumns="False" 
        CellSpacing="0"  GridLines="Both"
            ondeletecommand="RadGrid1_DeleteCommand" 
            onneeddatasource="RadGrid1_NeedDataSource" 
            onupdatecommand="RadGrid1_UpdateCommand" 
        oninsertcommand="RadGrid1_InsertCommand" onitemcreated="RadGrid1_ItemCreated" 
            onitemdatabound="RadGrid1_ItemDataBound" 
            Skin="Office2007" onitemcommand="RadGrid1_ItemCommand">

    There is a Page-Size dropdown at the bottom of grid, having 5,10,20,50 as options. right now there are only 6 records, 
    if user selects page size to 20 or 50,  the paging controls disappear.    What if user wishes to reset or set a new pagesize ?

    We want that the pagesize control should remain on screen.  any workaround ?

    -JD





  2. Answer
    Jayesh Goyani
    Jayesh Goyani avatar
    2732 posts
    Member since:
    May 2010

    Posted 23 Sep 2011 Link to this post

    Hello J,

    Please set below property.

    <PagerStyle AlwaysVisible="true" />

    let me know if any concern.

    Thanks,
    Jayesh Goyani
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. JD.
    JD. avatar
    37 posts
    Member since:
    Aug 2012

    Posted 23 Sep 2011 Link to this post

    Sincerely Jayesh, Your avatar is so connected to my state of mind, I guess its emotion of every developer
    when he is traped in a bug or solving issues.    it gives me little smile watching it.

    Thanks for the answer.
    - JD.
  5. Jayesh Goyani
    Jayesh Goyani avatar
    2732 posts
    Member since:
    May 2010

    Posted 23 Sep 2011 Link to this post

    Hello J,

    Thanks a lot.

    Thanks,
    Jayesh Goyani
Back to Top