Grid Expand Doesn't work in IE9 after back navigation

2 posts, 0 answers
  1. Joe
    Joe avatar
    10 posts
    Member since:
    Jun 2011

    Posted 11 Oct 2012 Link to this post

    Visual Studio 2010, C#, Telerik 2012.2.814.40

    Master page with RadAjaxManager
    Content page with RadAjaxManagerProxy

    1. Start up - Default Page_Load triggered: Check
    2. Expand row in grid - Page_Load triggered: Check
    3. Navigate away from page, click back button - Page_Load not triggered
    4. Click to Expand row - Page_Load triggered, but row does not expand (this also happens when I try and filter)
    5. Click to Expand row again - Page_Load triggered and row expands

    This is not an issue in FireFox or Chrome. It seems that when I navigate away from the page with the Grid and click the back button to go back, the Grid won't work the first time (Row expand, filtertemplate, etc..)
  2. Maria Ilieva
    Admin
    Maria Ilieva avatar
    4017 posts

    Posted 16 Oct 2012 Link to this post

    Hi Joe,

    I tried to replicate the described issue locally by adding a redirect button in the online demo below, but to no avail:
    http://demos.telerik.com/aspnet-ajax/grid/examples/hierarchy/nestedviewtemplatedeclarativerelations/defaultcs.aspx

    Please do let me know if you are able to replicate the problematic behaviour in the mentioned demo and if any specific settings are required.

    Kind regards,
    Maria Ilieva
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top