Get rid of whitespace in ScheduleView

3 posts, 1 answers
  1. Thomas
    Thomas avatar
    2 posts
    Member since:
    Sep 2013

    Posted 23 Sep 2015 Link to this post

    Hey,

    Im using the RadScheduleView Control with different ViewDefinitions as below.

    <telerik:RadScheduleView.ViewDefinitions>
                        <telerik:DayViewDefinition Orientation="Horizontal"
                                                   GroupHeaderDateStringFormat="{}{0: dddd dd/MMM}"
                                                   GroupFilter="{Binding GroupFilter}"
                                                   AppointmentFilter="{Binding AppointmentsFilter}"
                                                   />
     
                        <telerik:TimelineViewDefinition Title="Week"
                                                        VisibleDays="7"
                                                        GroupFilter="{Binding GroupFilter}"
                                                        TimerulerMajorTickStringFormat="{}{00:%H:mm}"
                                                        AppointmentFilter="{Binding AppointmentsFilter}"
                                                        LargeChangeInterval="7d"
                                                        TimerulerGroupStringFormat="{}{0: dddd dd/MMM}"
                                                        StretchAppointments="True" StretchGroupHeaders="True"
                                                        />
                        <telerik:TimelineViewDefinition Title="Month"
                                                        VisibleDays="30"
                                                        GroupFilter="{Binding GroupFilter}"
                                                        AppointmentFilter="{Binding AppointmentsFilter}"
                                                        TimerulerGroupStringFormat="{}{0: dd/MMM}"
                                                        TimerulerMajorTickStringFormat="{}{00:%H:mm}"
                                                        LargeChangeInterval="1m"/>
                    </telerik:RadScheduleView.ViewDefinitions>

    If i start my Programm on a monitor with high resolution there is a white space on the right side of the scheduler in each ViewDefinition ( see attached image ).

    Is it possible to stretch the ScheduleView over the complete Monitor and get rid of this white field?

    Thanks

    Thomas

  2. Answer
    Kalin
    Admin
    Kalin avatar
    1209 posts

    Posted 28 Sep 2015 Link to this post

    Hi Thomas,

    Try setting the MinTimeRulerExtent property of RadScheduleView to higher value, by default it is 1400.

    Hope this helps.

    Regards,
    Kalin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for WPF is Visual Studio 2017 Ready
  4. Thomas
    Thomas avatar
    2 posts
    Member since:
    Sep 2013

    Posted 28 Sep 2015 in reply to Kalin Link to this post

    Hey Kalin,

    Thanks a lot for the answer.

     

Back to Top