Functionality of "RemoveElement" removes HTML tag but not tag content.

2 posts, 0 answers
  1. Mark Kucera
    Mark Kucera avatar
    84 posts
    Member since:
    Sep 2009

    Posted 22 Jul 2015 Link to this post

    Hey guys we've noticed a change in how the RemoveElement feature of the WYSIWYG works.  Previously clicking RemoveElement in the editor caused the specified tag, and it's contents to be removed, now it's only removing the tag.  The tag's inner content remains in the document.  We desire to have the previous functionality restored.  This was a very useful feature, especially for training users who don't have much HTML knowledge to edit complex html documents with messing them up. I've reproduced this issue using your demo projects and recorded it in a video here:


    Please let me know how we can restore this feature to it's previous functionality.



  2. Ianko
    Ianko avatar
    1507 posts

    Posted 27 Jul 2015 Link to this post

    Hi Mark,

    Thank you for contacting Telerik support.

    The described remove element buttons is designed to work that way. This behavior is such as of the creation of this button and there are no changes regarding its output. You can examine this screencast——, where it is shown that using the 2015 Q1 version the output is the same as described.

    Let me know if I can do anything further to help.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
Back to Top