FullScreenMode not working

2 posts, 0 answers
  1. Mark Taylor
    Mark Taylor avatar
    2 posts
    Member since:
    Jan 2009

    Posted 25 Aug 2009 Link to this post

    Problem:
    I just upgraded from an older 2008 version to the latest Q2 2009 only to discover that the RadSpltter is no longer sizing to the full screen height. This has broken all my current solutions implemented using the splitter to control page layout. I upgraded because the older 2008 version was broken for IE8 forcing me to uninstall IE8 and reinstall IE7...this is blocking my deployment of a new solution so any help would be appreciated.

    System:
    Windows XP Professional with SP3
    Internet Explorer 7 with all patches and updates.
    Visual Studio 2008 with SP1 and the 3.5 SP1 .NET Framework
    SQL Server 2008 with latest SP and all patches
    Telerik RadControls for ASP.NET AJAX Q2 2009 NET35

    Repro Steps:

    • Using 'Add Remove Programs' Uninstall Telerik RadControls for ASP.NET AJAX 2008
    • Reboot system
    • Install Telerik RadControls for ASP.NET AJAX Q2 2009 NET35
    • Reboot system
    • Launch Visual Studio and create new ASP.NET Web Application (note: toolbox now has tabs for .NET20 and .NET35 versions of the RedControls - I repro'ed this with both sets)
    • Add a RadScriptManager to the Default.aspx page and register it in the WebConfig
    • Add a RadSplitter with a single RadPane
    • Set the FullScreenMode property of the RadSplitter to 'true'
    • Set the BackColor of the RadPane to 'red'
    • Build and run

     

     

    Expected:

    The RadSplitter to automatically resize to the browser such that the full page appears red.

    Actual:
    The RadSplitter resizes to the browser width but the height remains fixed at about 400 pixels. Manually setting the width and height to '100%' has no effect.

  2. Svetlina Anati
    Admin
    Svetlina Anati avatar
    2795 posts

    Posted 26 Aug 2009 Link to this post

    Hello Mark,

    I already answered your other thread and for your convenience and for others who might encounter the same issue I pasted my reply below:

    The FullScreenMode property is obsolete and it is not recommended to use it.
    When you have the RadSplitter configured in percentages, all its parent elements including the body, form and html should have their size explicitly set either in percentages or pixels in order to let the splitter calculate the size it should take. This is not new and I do not know why it worked in your previous version - you can see a sample demo explaining this below:

    http://demos.telerik.com/aspnet-ajax/splitter/examples/resizewithwindow/defaultcs.aspx

    This being said, you will get the desired behavior by adding the following style to your page:

     

      <style type="text/css">     
        html, body, form     
        {     
          height: 100%;     
          margin: 0;     
          padding: 0;     
        }     
             
        </style>   

    Do not forget to set height to all the other parent elements if there are such (e.g DIV, TABLE, TR, TD, etc).

    On a side note, I also suggest to set VisibleDuringInit=false for the splitter - this will hide the initial resizing of the splitter from the end user and you will get a better behavior.

    I hope that my explanations and suggestions are helpful, let me know how it goes.


    Kind regards,
    Svetlina
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top