Fiddler not capturing iOS traffic even though echo service works

4 posts, 1 answers
  1. Mark
    Mark avatar
    7 posts
    Member since:
    Dec 2015

    Posted 16 Dec 2015 Link to this post

    I upgraded Fiddler to the latest version (v2.6.1.5) and for some reason it is no longer capturing iOS traffic. I have not actually tried this for many months so admittedly the problem may be unrelated to the upgrade.

    I have done this many times in the past where I set the HTTP Proxy on my device to the IP of the machine running Fiddler and it instantly captures all the traffic.
    I verified all the settings and everything seems fine. In fact, when I visit http://myip:8888 from my device I successfully receive the Fiddler Echo Service. However no traffic is being captured.

    My setup is a laptop and iphone both on the same non-corporate wifi network. 

    Any ideas?

    Thank you

  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 16 Dec 2015 Link to this post

    Hi, Mark--

    Thanks for the thorough information!

    If you see the Echo Service page on the device, that means there's no problem with network connectivity between the device and the Fiddler PC.

    When you see the Echo Service page on the device, do you see a corresponding entry in Fiddler's Web Sessions list?

    If you click Help > Troubleshoot and then browse with the device, do you see entries in Fiddler's Web Sessions list that are marked in a strike-through font?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Mark
    Mark avatar
    7 posts
    Member since:
    Dec 2015

    Posted 16 Dec 2015 Link to this post

    Hi Eric,

    Thanks for the response. Cool, I didn't know about that troubleshoot option. I did as you said and indeed my mobile browsing is showing with a strike-through! The reason given is 'Hidden due to Status Bar> Process Filter.'

    How do I change the status bar process filter settings? 

     

  4. Answer
    Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 16 Dec 2015 Link to this post

    Hello, Mark--

    If you look at the Status Bar across the bottom of the Fiddler window, the second little "tray" in that bar probably says something like "Web Browsers." Click that and then change to "All Processes."

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top