Expander's content Widht Problem

2 posts, 0 answers
  1. bob thomash
    bob thomash avatar
    35 posts
    Member since:
    Oct 2009

    Posted 26 Mar 2010 Link to this post

    Hello Friends !
    I set many  Textbox in RadExpander As content. but Width = "*" not working. Privious Telerik Control every thing is ok but now with new DLL , Not Supported. I cannot Repoduce this situation so i cannot Send Sample.My all Textboxes become small Psl See my Screenshots.
     

    See Screenshots. All TextBoxes Become small becoz Width = "*" not supported by expander
  2. Ivan
    Admin
    Ivan avatar
    519 posts

    Posted 28 Mar 2010 Link to this post

    Hi Bob,

    Thank you for contacting us.

    After previewing the attached here picture we found all the information is lay-outed in a grid (which is located in an expander's content). We think the source of this issue is the value of the Grid's HorizontalAlignment - it's "Left", but in should be "Stretch". About the Width="*" - please note this initialization makes sense  for Grid's Columns, but not for TextBox controls.

    Please preview the attached here example project. There are two expanders. In the first one we Stretched a grid with text boxes. In the second expander we just Left Aligned the same grid with the same text boxes.

    We hope the information above will help you. However if you have other questions just drop us a line.


    All the best,
    Ivan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft banner
Back to Top