Error in WebResource cause VS hanging for 5 minutes

7 posts, 0 answers
  1. James Faw
    James Faw avatar
    17 posts
    Member since:
    May 2009

    Posted 31 May 2010 Link to this post

    My VS is hanging 5-10 minutes, once some error happens in WebResource.axd. When error happens (I don't say that they are Telerik's bugs) I see immediately the error but after that VS starts to load full WebResource file which takes 5-10 minutes. I have set IE options for debugging to false, but it doesn't help to stop loading this file.

    Are there any ideas what else can I do?
  2. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 03 Jun 2010 Link to this post

    Hello James,

    Could you please host the site in IIS and try it again? Do you experience the same loading issue? If not, I recommend you to reinstall Visual Studio. Also I recommend you to test the same page on different machines with different browsers.

    In case that the provided information does not help, could you please open a new support ticket and send me a project which shows the problem. I will check it and do my best to provide a solution as soon as possible.

    Best wishes,
    Fiko
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. James Faw
    James Faw avatar
    17 posts
    Member since:
    May 2009

    Posted 03 Jun 2010 Link to this post

    Maybe I explained not clear. It doesn't matter what the project is. It is not related to IIS or site. Because once the project is on the site, it is usual behavior. You see yellow warning and it is it. What I am speaking about that if for some reason I did mistake which causes any Javascript error I get breakpoints within any jcript in VS. But usual jscript are small and it doesn't take a lot of time to load. However, when error happens within WebResource.axd my VS is hanging. I didn't open support ticket, because it is not directly Telerik-related problem. I just am trying to find solution to disable debugging of JScript and VS will stop to load JScript for debugging. It is all.
  5. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 09 Jun 2010 Link to this post

    Hello James,

    I understood that the problem maybe is not directly related to Telerik control. I have asked you to host the site in IIS and/or test the same site on different Visual Studios installed on different machines in order to isolate the problem. Did you perform these test? If so, did the same error appear?

    In general, you can disable script debugging in IE by checking the "Disables script debugging" (it is disabled by default). You need to open "Tools -> Internet Options -> Advanced" in order to do this. The checkbox (actually there are 2 checkboxes) is child of the "Browsing" node in the "Settings" tree. Please note that, however, this will not disable the error notification message of the browser.

    I helps this helps.

    Kind regards,
    Fiko
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. James Faw
    James Faw avatar
    17 posts
    Member since:
    May 2009

    Posted 09 Jun 2010 Link to this post

    1. This site is our application which we deploy to our clients. So, this error as I said happens on the client computer. (The error I speak about is in the ticket I created and called "Grid within Grid". I just separated those 2 issues). We just see warning at the bottom.
    2. For some reason, on other computers it doesn't happen. I mean, they see the error and it doesn't go inside of axd-file (breakpoint) and VS isn't hanging.
    3. Yes, I verified those flags and they are on (disabled).
  7. Fiko
    Admin
    Fiko avatar
    1406 posts

    Posted 14 Jun 2010 Link to this post

    Hi James,

    The provided information is not enough for me to determine the exact reason for the error that you experience. This is why, could you please open a new support ticket and send me a runnable project which shows the problem? I will check it and do my best to provide a solution as soon as possible.

    All the best,
    Fiko
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. James Faw
    James Faw avatar
    17 posts
    Member since:
    May 2009

    Posted 14 Jun 2010 Link to this post

    We still are speaking about different things. I don't care about the error I have. I tried to find out about VS functionality solution. I hoped that someone else have experienced such hanging before, too. Just forget about the error. ERROR is OK. It should be. I just try to find out why my VS is hanging out and other don't for the same mistake. What exactly different in my VS or Windows configuration that cause this hanging. Because of that I've put it in "General discussions" and not in the ticket or other places. I cannot create PROJECT to give you, because even here there are developed who see the ERROR, but they don't wait for it 5 minutes and see almost immediately.

    P.S. Actually, you can close this thread, I am going to try on other forums to solve this problem.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017