Empty Data Source Type List in VS2012

5 posts, 0 answers
  1. Gary
    Gary avatar
    28 posts
    Member since:
    Apr 2011

    Posted 08 Jan 2013 Link to this post

    Initially it worked and then for some unknown reason, the Data Source Type list failed to appear at all.

    Would like to know if there's a workaround. Have tried a reinstall of Reporting and that does not change anything.

    How can I add a datasource in code that will appear in the designer. Have tried hacking the designer code but that gets overwritten.
    An example would be good otherwise it's going to prove difficult to use Reporting at all.

    Screen shot attached.

  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 10 Jan 2013 Link to this post

    Hello Gary,

    There was such a problem in earlier version of the product, that is resolved in the Q3 2012 release (v. 6.2.12.1017) of the product. If you're using this version or newer, please check whether the VS Toolbox contains a Tab for Telerik Reporting and whether this Tab is populated with report items. If such is missing or is empty, please choose Reset Toolbox from the context menu of Visual Studio Toolbox and try again. You need to have only a single VS instance opened at this time and you might have to restart Visual Studio after the reset.

    If after resetting the toolbox the report items are still missing we will appreciate if you go through the Telerik Reporting Toolbox items are missing article and send us the log.

    All the best,
    Steve
    the Telerik team

    HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

  3. DevCraft banner
  4. Negin
    Negin avatar
    8 posts
    Member since:
    Jun 2012

    Posted 23 Jan 2013 Link to this post

    Hi,
    Apparently i could solve the problem! :)
    I use VS 2012 and have Telerik (v. 6.2.12.1025) installed on my computer. i experienced the exact problem and i did what Steve said but it didn't worked! none of the telerik reporting items where in the toolbox and the data source selecting wizard showed no data sources to select! I reset the toolbox and there was no change in toolbox and data source wizard!

    ****************************************
    Do these steps, it worked for me, i hope the same for you ;) (This has been tested in VS 2012 Only!)

    1- Go to:  "Tools" ->  "Choose Toolbox Items"
              [Note: you can`t see "Choose Toolbox Items" in "Tools" menu if your VS is set to certain development settings. but you should see it if your VS is set to "General Development Settings", however if you want to reset your VS to "General Development Settings" follow these steps
             1- Go to: "Tools" -> "Import and Export Settings".
             2- Choose "Reset all settings" and click "Next".
             3- Choose the way you want VS to save your current settings. Consider that after VS resets you will loose all of your settings
                  so it is recommended that you create a backup of your current settings to export in VS later. Click "Next".
             4- Choose "General Development Settings" and click "Finish".
             5- Restart VS.

    2- Choose " .Net Framework Components" tab.
    3- Check all items related to Telerik assembly.
    [To do this you can sort the items by "Assembly Name"]. Click "OK".
    4- Restart VS.


    Now you should see all Telerik reporting Items and all available data sources when you open data source selecting wizard for your report! :)

    Good luck!
    Negin
  5. Paul D.
    Paul D. avatar
    7 posts
    Member since:
    Dec 2010

    Posted 26 Jun 2013 Link to this post

    Negin:
    Thank you !
    I have been through multiple forums, countless iterations of devenv /Resetyadayadayayda, uninstalls, reinstalls, etc...
    and it all turned out to be this totally simple thing !

    My setup was VS 2010, win7 64 bit, etc...
    -Paul D.
  6. Dave
    Dave avatar
    1 posts
    Member since:
    Mar 2013

    Posted 22 Oct 2013 Link to this post

    Thank You Negin! I experienced the same issue when upgrading to Reporting Q3 2013 for VS 2012, but this fix worked!!

    Dave
Back to Top
DevCraft banner