Edit mode doesn't have the right Culture

2 posts, 0 answers
  1. Ronald Evers
    Ronald Evers avatar
    26 posts
    Member since:
    Dec 2009

    Posted 07 Sep 2011 Link to this post

    Hi Telerik,

    We're using the NumericUpDown control for our currency input controls. However, I don't seem to be able to get the correct format to work in the edit mode. I want to use the European format, with Euros and a comma for decimals. Now on first glance this works fine, I've set the string format to C, and the ConverterCulture property to nl-NL. However when I enter edit mode, to change the number, it seems to jump back to the American standard, with a dot for decimals. When I then try and add 50 cents, by adding ",50" it actually adds 50 to the entire number. So 700,50 becomes 70050,00. Is there a way to set the correct culture for editing mode? I've attached a screenshot to make it easier to understand, please excuse my terrible paint skills.
  2. Yana
    Yana avatar
    4547 posts

    Posted 13 Sep 2011 Link to this post

    Hello Ronald,

    I'm afraid that these settings of RadNumericUpDown in edit mode cannot be easily changed - this is by design.

    We're sorry for the inconvenience this may cause to you.

    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft R3 2016 release webinar banner
Back to Top