Duplicate RadControls in toolbox

8 posts, 1 answers
  1. Shawn Knight
    Shawn Knight avatar
    4 posts
    Member since:
    Jul 2010

    Posted 07 Jul 2010 Link to this post

    Hi,

    I am using Visual Studio 2008 SP1 and have just installed RadControls for ASP.NET AJAX Q1 2010.  There have been no previous installations of RadControls or Visual Studio on this machine.  

    After installing RadControls for ASP.NET AJAX Q1 2010 I noticed that there are two of every RadControl in the toolbox.
    Why is this and is there a way to fix it?
     
  2. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 08 Jul 2010 Link to this post

    Hi Shawn,

    This happens because the RadControls installer actually contains three different assemblies, built targeting specific .NET Framework versions. Two of them (located in the bin20 and bin35 folders respectively) are applicable for use in Visual Studio 2008 and get registered to the ToolBox. The Visual Studio 2008 ToolBox does not provide an interface to filter the items depending on the TargetFramework, which results in the items duplicated. FYI, the ToolBox item filtering is fixed in VS2010.

    You can easily have only one RadControls group if you don't use the other. To do that, please, uninstall RadControls, then start the installer again and click the Custom button when asked to choose the setup type. In the next screen, deselect the .NET 20 Components feature (providing you'd use only the .NET35 controls) and continue with the installation.

    Let me know if that helps.

    Kind regards,
    Erjan Gavalji
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Shawn Knight
    Shawn Knight avatar
    4 posts
    Member since:
    Jul 2010

    Posted 08 Jul 2010 Link to this post

    Actually I am not sure that is the same issue.  The issue I was having is that under both the .Net 20 and .Net 35 tool box categories each control was listed twice.  So if you expanded any of the RadControl categories (and sorted alphabetically) you would see for example: "RadDock" twice in a row.  
    Another interesting issue we had with the tool box after the install of Q1 was that one of our installs resulted in an empty toolbox.  The RadControl categories were there but the listed no controls.

    The solution to both these issues was staring us in the face however.  All that was required was right clicking on the tool box and clicking on "Reset Toolbox".

    Thanks 
  5. Answer
    Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 09 Jul 2010 Link to this post

    Hi Shawn,

    Yes, we noticed that sometimes the VS2010 toolbox does not get updated automatically. Unfortunately we haven't been able to identify the exact circumstances in order to implement a decent solution. In most of the cases a toolbox Reset fixes the problem though (as you've found yourself).

    Kind regards,
    Erjan Gavalji
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Dave Galligher
    Dave Galligher avatar
    37 posts
    Member since:
    May 2010

    Posted 13 Feb 2012 Link to this post

    I've noticed the following behavior after performing these steps (the Reset Toolbox option):

    Controls that were there before are now gone, items like the RadTextBox, Rad Button controls, etc. are GONE. Controls that are broken up individual groups appear multiple times such as RadThemeManager, I've tried this now four times and now I have four instances in the toolbox - each time I reset it, it adds it again and again and again.... Groups this happens in: RadControls for WinForms - Themes 2011 Q3, RadControls for WinForms - Dialogs 2011 Q3, RadControls for WinForms - Data Controls 2011 Q3, RadControls for WinForms 2011 Q3, RadControls for WinForms - Containers 2011 Q3

    This is incredibly frustrating. 
  7. Andrey
    Admin
    Andrey avatar
    244 posts

    Posted 17 Feb 2012 Link to this post

    Hello Dave,

    I am sorry to hear you are experiencing such issues. While a few customers have reported the issue, we are still not able to get a solid repro.

    It would be most helpful if you could send us a Visual Studio activity log. You start Visual Studio with logging enabled by using the following command line:
    C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe /log C:\Temp\VisualStudioActivity.log

    Having done that, you can try to reproduce the issue and then send us the log.

    If you have any concerns about privacy, you can send us your log via a support ticket rather than the public forums.

    Best Regards,
    Andrey
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  8. Ronny
    Ronny avatar
    2 posts
    Member since:
    Feb 2012

    Posted 25 Oct 2012 Link to this post

    Having the same problem and it's duplicating up to 4 times for each control. I have tried doing a reset and nothing..
  9. Petar
    Admin
    Petar avatar
    219 posts

    Posted 30 Oct 2012 Link to this post

    Hello Ronny,

    Can you check whether the following forum thread addresses the issue on your side?
    http://www.telerik.com/community/forums/aspnet-ajax/vs-extensions/multiple-radcontrols-entries-in-the-toolbox.aspx

    Regards,
    Petar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017