ContentTemplate with RadSitemap

2 posts, 0 answers
  1. Fit2Page
    Fit2Page avatar
    345 posts
    Member since:
    Feb 2007

    Posted 01 Apr 2015 Link to this post

    Clicks are # in ContentTemplate with RadSitemap and  is not working on iPad.
    Please check http://sieger.ontwikkelruimte.nl/test.aspx

    With code:

    <telerik:RadMenu id="RadMenu2" EnableShadows="false" ExpandAnimation-Type="None" CollapseAnimation-Type="None" ShowToggleHandle="false" CausesValidation="False" runat="server" >

             <Items>

               



                   <telerik:RadMenuItem Value="Producten" Text="Producten" PostBack="false">
                            <ContentTemplate>
                                <div>
                                  
                                    <telerik:RadSiteMap ID="RadSiteMap2" runat="server" Skin="Telerik" EnableTextHTMLEncoding="true">
                                        <LevelSettings>
                                            <telerik:SiteMapLevelSetting Level="0">
                                                <ListLayout RepeatColumns="3" RepeatDirection="Vertical" />
                                            </telerik:SiteMapLevelSetting>
                                        </LevelSettings>

                                       <Nodes>
                                           <telerik:RadSiteMapNode NavigateUrl="~/abc.aspx" Text="henk" />
                                       </Nodes>
                                        </telerik:RadSiteMap>
                                    </div>
                                </ContentTemplate>
                            </telerik:RadMenuItem>

                 </Items>
         </telerik:RadMenu>
  2. Dimitar
    Admin
    Dimitar avatar
    281 posts

    Posted 06 Apr 2015 Link to this post

    Hi,

    This is a known issue. It has been logged for fixing. You can vote on its public Ideas and Feedback portal item for it. You can also add comments and track its status by clicking the "Follow this item" button.

    As a workaround, you could try using an ItemTemplate, instead of Content template. The code would change as follows:

    <telerik:RadMenu ID="RadMenu2" EnableShadows="false" ExpandAnimation-Type="None" CollapseAnimation-Type="None" ShowToggleHandle="false" CausesValidation="False" runat="server">
        <Items>
            <telerik:RadMenuItem Value="Producten" Text="Producten" PostBack="false">
                <Items>
                    <telerik:RadMenuItem runat="server">
                        <ItemTemplate>
                            <div>
                                <telerik:RadSiteMap ID="RadSiteMap2" runat="server" Skin="Telerik" EnableTextHTMLEncoding="true">
                                    <LevelSettings>
                                        <telerik:SiteMapLevelSetting Level="0">
                                            <ListLayout RepeatColumns="3" RepeatDirection="Vertical" />
                                        </telerik:SiteMapLevelSetting>
                                    </LevelSettings>
                                    <Nodes>
                                        <telerik:RadSiteMapNode NavigateUrl="http://google.com" Text="Google" />
                                    </Nodes>
                                </telerik:RadSiteMap>
                            </div>
                        </ItemTemplate>
                    </telerik:RadMenuItem>
                </Items>
            </telerik:RadMenuItem>
        </Items>
    </telerik:RadMenu>


    Regards,
    Dimitar
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top