Chart Control / Handler / Web.Config

Thread is closed for posting
3 posts, 0 answers
  1. Yves
    Yves avatar
    8 posts
    Member since:
    Mar 2010

    Posted 13 Dec 2011 Link to this post

    Hi,

    Must be a tiresome topic, since there are lots of post about this, but still i didnt manage to make it work.
    i run IIS 7.5 under Windows Server 2008 R2. and i simply want to show some charts on a simple website.
    instead of a chart i always can see the message:
     "The Chart http handler is not registered. Please, manually add the following line to your Web.config httpHandlers section:
    <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2010.3.1317.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />"


    i read here about how i should register the handler:
    http://www.telerik.com/help/aspnet-ajax/introduction-troubleshooting.html
    i also read here:
    http://www.telerik.com/help/aspnet-ajax/introduction-registering-the-httphandlers-on-windows-vista-iis-7-integrated-mode.html

    i tried to use the classic mode (pipline) instead of integrated, but then i get either an Error 500 or 404.

    the library "Telerik.Web.UI.dll" is in the bin folder of the web application.

    if you wanna make me really happy, please tell me what i have to write into my Web.Config.

    my current Web.Config:
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <connectionStrings>
        <-- some connection strings -->
      </connectionStrings>
      <appSettings>
        <-- some settings -->
      </appSettings>
      <system.web>
        <compilation debug="false" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Speech, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </assemblies>
        </compilation>
        <customErrors mode="Off" defaultRedirect="Error.aspx">
          <error statusCode="404" redirect="/NotFound.aspx" />
        </customErrors>
      </system.web>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
        <handlers>
            <add name="Telerik.Web.UI.WebResource"  path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" />
            <add name="ChartImage.axd" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" />
        </handlers>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>
      <system.web.extensions>
        <scripting>
          <webServices>
            <jsonSerialization maxJsonLength="999999999" />
          </webServices>
        </scripting>
      </system.web.extensions>
    </configuration>

  2. Giuseppe
    Admin
    Giuseppe avatar
    2363 posts

    Posted 16 Dec 2011 Link to this post

    Hello Yves,

    The easiest way is to use the design-time smart tag ("Add RadChart HTTP Hanlder to Web.config" option).

    Alternatively, if you are adding the web.config entries manually, you either need to define the handlers in both system.web and system.webServer sections, or if you are adding them only to the system.webServer section, you need to set RadChart.EnableHandlerDetection property to false:
    <?xml version="1.0"?>
        ...
      <system.web>
        ...
        <httpHandlers>
            ...
          <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
        </httpHandlers>
        ...
      </system.web>
      ...
      <system.webServer>
        ...
        <handlers>
            ...
          <add name="ChartImage_axd" verb="*" preCondition="integratedMode" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" />
        </handlers>
      </system.webServer>
        ...
    </configuration>


    All the best,
    Giuseppe
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Yves
    Yves avatar
    8 posts
    Member since:
    Mar 2010

    Posted 16 Dec 2011 Link to this post

    Hi Giuseppe

    Thanks for the answer, but this was not the problem since i tried that before. i read all the forum posts and figured my web.config must be something like the thing below, which is slightly different from your version.
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        ...
     <system.web>
     ...
        <httpHandlers>
            <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2010.3.1317.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />
        </httpHandlers>
      </system.web>
      ....
      <system.webServer>
        <handlers>
            <add name="ChartHandler" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI" />
        </handlers>
      </system.webServer>
      ....
    </configuration>

    But this did not give me my chart.

    the good news is that i just found the solution myself in the very moment i received your email.
    i repaired the .NET Framework 4.0 on my server.
    see http://www.itcsolutions.eu/2010/09/06/solution-for-http-error-500-21-internal-server-error-bad-module-managedpipelinehandler-on-iis-7-5/ for description
    now i can finally see the charts.

    Regards,
    Yves



Back to Top