Cannot set "02:00" in TimePicker

6 posts, 0 answers
  1. Marc
    Marc avatar
    39 posts
    Member since:
    Nov 2012

    Posted 10 Mar 2013 Link to this post

    I don't know if it's a new bug but it's impossible to set 02:00 in a TimePicker as you can see in your example at:

    http://demos.telerik.com/aspnet-ajax/calendar/examples/datetimepicker/overview/defaultcs.aspx

    Each time we enter or select 02:00, it automatically change for 01:00. All other times in the picker from the demo works but I didn't check for all times we can enter manually.

    Someone can fix that please...

    Thanks
  2. Kevin
    Kevin avatar
    360 posts
    Member since:
    Jul 2012

    Posted 11 Mar 2013 Link to this post

    That's a pretty interesting bug. It seems to only allow you to select 2:00 AM when it's the first one you select from the popup. Once you select another time and then try to select 2:00 AM again, it resets the values to 1:00 AM.

    I didn't experience the manual typing issue, as that worked for me.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Marc
    Marc avatar
    39 posts
    Member since:
    Nov 2012

    Posted 11 Mar 2013 Link to this post

    Hi Kevin, you are right...I tried again and I have no problem with the manual input which I had in my web page. Today it's fine but I still have the bug with the Time Popup.
  5. Andrey
    Admin
    Andrey avatar
    836 posts

    Posted 14 Mar 2013 Link to this post

    Hi,

    I tried to replicate the issue you are facing but to no avail. I made a video recording to illustrate how things are looking on my side.

    Kind regards,
    Andrey
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Marc
    Marc avatar
    39 posts
    Member since:
    Nov 2012

    Posted 14 Mar 2013 Link to this post

    Hi Andrey, what to say? Your demo works now, I tried it myself, and our web site too...very strange. I know the bug exists, Kevin has the same bug (see previous posts).

    The only idea I have, which I just realized, is that 2:00 is the time at which we change the clock for the Daylight Saving Time which was last week-end here. But I saw the bug before and after the DST change. I don't know if's related or not but it's a clue. Otherwise, since now it work I have nothing else to say than nice fix since nothing has been changed ;-)

    If I see the same bug later, I will post another message...

    Thanks
  7. Andrey
    Admin
    Andrey avatar
    836 posts

    Posted 19 Mar 2013 Link to this post

    Hello,

    Yes, may be the problem was caused by the daylight saving time. You could check this forum thread for an explanation of the DST problem.

    Greetings,
    Andrey
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017