Can I use Radeditor Lite version in my customization webpart coding?

3 posts, 0 answers
  1. selva
    selva avatar
    8 posts
    Member since:
    Jun 2011

    Posted 08 Jul 2011 Link to this post

    Hi

    I tried to use radeditor 4.5.6 in my webpart coding. I am getting the error message as "The type 'Telerik.SharePoint.MOSSRadEditor' has no constructors defined". It means "Radeditor Lite version" ?. Can we use this version in my webpart coding?.  I can't craete a instance for MoassRadEditor class. How can I use? if it is possible. Please guide me the correct way.

    Thanaks in advance

  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 08 Jul 2011 Link to this post

    Hi Selva,

    Unfortunatly you can not achieve the desired functionality. In the Light version of RadEditor for MOSS the MOSSRadEditor class does not have a public constructor. This is a limitation of the free version of RadEditor for MOSS. In order to initiate an instance of  MOSSRadEditor class you need to use RadEditor for MOSS 5.x.x, or paid version of RadEditor from MOSS (4.x.x).


    Best wishes,
    Stanimir
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>


  3. selva
    selva avatar
    8 posts
    Member since:
    Jun 2011

    Posted 09 Jul 2011 Link to this post

    Thanks a lot
Back to Top