Can't run tests on Internet Explorer after Update 2014.3.903 from September 3rd

4 posts, 0 answers
  1. Oleg
    Oleg avatar
    2 posts
    Member since:
    Jul 2013

    Posted 24 Sep 2014 Link to this post

    Hello guys
    Please Help if anyone faced the same issue after latest Framework update from September 3rd

    Here is the thing:
    When I launch tests (which previously run OK) on IE10 it just opens Internet Explorer and waits ForBrowserToConnect but fails in a while. Browser remains open but test execution fails with following 'explanation':

    SetUp : System.TimeoutException : Wait for condition has timed out
    TearDown : System.NullReferenceException : Object reference not set to an instance of an object.

       at ArtOfTest.Common.WaitSync.CheckResult(WaitSync wait, String extraExceptionInfo, Object target)
       at ArtOfTest.WebAii.Core.Manager.WaitForBrowserToConnect(Int32 browserIndexToWaitFor)
       at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle, String arguments)
       at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle)

  2. Boyan Boev
    Admin
    Boyan Boev avatar
    1039 posts

    Posted 29 Sep 2014 Link to this post

    Hi Oleg,

    Have you configured the browser according to our documentation after upgrading?

    Please try that out and let me know the results.

    Regards,
    Boyan Boev
    Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
  3. Oleg
    Oleg avatar
    2 posts
    Member since:
    Jul 2013

    Posted 29 Sep 2014 in reply to Boyan Boev Link to this post

    Hi Boyan, 

    Yes, configuration was performed in accordance to the documentation.

     And still no results.

  4. Boyan Boev
    Admin
    Boyan Boev avatar
    1039 posts

    Posted 02 Oct 2014 Link to this post

    Hi Oleg,

    Could you please send us your test project so we can try reproducing this issue. We don't need an access to your application, just the test.

    Hope to hear from you soon.

    Regards,
    Boyan Boev
    Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
Back to Top