Can't play local MP4 files

6 posts, 0 answers
  1. Pete
    Pete avatar
    11 posts
    Member since:
    Feb 2011

    Posted 03 Mar 2014 Link to this post

    tried everything to play local MP4 files in media player, but can't get it to happen.

    Added to web.config:
    <remove fileExtension=".mp4" />
    <remove fileExtension=".ogv" />
    <remove fileExtension=".webm" />
    <remove fileExtension=".mp3" />
    <remove fileExtension=".ogg" />
    <remove fileExtension=".wav" />
    <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
    <mimeMap fileExtension=".ogv" mimeType="video/ogg" />
    <mimeMap fileExtension=".webm" mimeType="video/webm" />
    <mimeMap fileExtension=".mp3" mimeType="audio/mpeg" />
    <mimeMap fileExtension=".ogg" mimeType="audio/ogg" />
    <mimeMap fileExtension=".wav" mimeType="audio/wav" />

    tried various paths, and the sample code from Telerik, but I just can't get them to play. I can play a youtube video without a problem, but not local files.

    Code is:-
    ​RadMediaPlayer1.ToolbarDocked = true;
    RadMediaPlayer1.ToolBar.FullScreenButton.Visible = true;
    RadMediaPlayer1.ToolBar.HDButton.Visible = true;
    RadMediaPlayer1.Source = filename;
    RadMediaPlayer1.Title = title;
    RadMediaPlayer1.Skin = Session["Skin"].ToString();
    RadMediaPlayer1.AutoPlay = true;

    Filename is passed through, and could be a youtube URL or a path such as ~/App_Documents/FindACosta.mp4


  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 04 Mar 2014 in reply to Pete Link to this post

    Hi Pete,

    Please have a look into the sample code snippet which works fine at my end and also take a look into this forum thread which discuss about the same scenario.

    RadMediaPlayer RadMediaPlayer1 = new RadMediaPlayer();
    RadMediaPlayer1.Width = 700;
    RadMediaPlayer1.Height = 500;
    RadMediaPlayer1.Source = "../Videos/RadControls.mp4";

  3. DevCraft R3 2016 release webinar banner
  4. Pete
    Pete avatar
    11 posts
    Member since:
    Feb 2011

    Posted 04 Mar 2014 Link to this post

    sorry - this doesn't seem to work for me - firefox just seems to spin its wheels.

    I have sent you the project in an email


  5. Eyup
    Eyup avatar
    2942 posts

    Posted 06 Mar 2014 Link to this post

    Hello Pete,

    Can you please verify whether your sample source works as expected with regular HTML5 video tag?

    Looking forward to your reply.


    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

  6. Eric
    Eric avatar
    2 posts
    Member since:
    Sep 2011

    Posted 21 Apr 2015 Link to this post



    Please make sure that .mp4 is configured to be an available MIME type in IIS.  To add it in IIS 7


    1.  Select your website in IIS.

    2.  Select "MIME Types" under the IIS section in the middle.

    3.  Click "Add..." and do ".mp4" for the File name extention and "video/mp4" for the MIME type.


    Save it and give it another try!

  7. Eyup
    Eyup avatar
    2942 posts

    Posted 24 Apr 2015 Link to this post

    Hi Eric,

    Thank you for sharing this approach with our community. You can also check the option to add mimeSettings in the web.Config file:


    See What's Next in App Development. Register for TelerikNEXT.

Back to Top
DevCraft R3 2016 release webinar banner