ButtonChrome

4 posts, 0 answers
  1. Patrik
    Patrik avatar
    56 posts
    Member since:
    Jul 2010

    Posted 22 Mar 2011 Link to this post

    Hello Telerik!

    I have created my own version of the ButtonChrome template by creating it in Blend and the altering it according to my instructions. The problem I have is that the changes doesn't seem to affect all controls using it. If I export any control style in Blend and the put it in my theme-dll it will work, even though I don't change anything. Is it possible to force my ButtonChrome style to be the one that is used by all controls using the ButtonChrome control?

    Best regards,
    Patrik Edberg
  2. Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 24 Mar 2011 Link to this post

    Hi Patrik,

    You can create a custom theme project that uses your new ButtonChromeStyle and use this custom theme for the controls you need. For more info on how to create a custom theme , you can examine this article. You can also send us a project demosntrating the issue you have faced, this way we would be better able to assist you.

    Greetings,
    Petar Mladenov
    the Telerik team
  3. DevCraft banner
  4. Patrik
    Patrik avatar
    56 posts
    Member since:
    Jul 2010

    Posted 25 Mar 2011 Link to this post

    I will submit a Support Ticket for this subject.
  5. Patrik
    Patrik avatar
    56 posts
    Member since:
    Jul 2010

    Posted 25 Mar 2011 Link to this post

    I solved the problem by adding empty resource dictionary files to the project. I assume one such file should exist for each included reference to Telerik dlls.
Back to Top