Bulleted list

8 posts, 0 answers
  1. Thomas
    Thomas avatar
    7 posts
    Member since:
    Apr 2010

    Posted 29 Apr 2010 Link to this post

    We have some problems with the RadEditorMOSS 5.0.1.
    When our users adds a bulleted list in the editor, it often ends up with an extra bullet. When they try to remove the bullet and then save, the bullet suddenly reappears. They have to do this three or four times before it disappears. What is the reason for this, and what can we do avoid it?

    Thomas
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 30 Apr 2010 Link to this post

    Hello Thomas,

    The reason for this behavior is the ConvertToXhtml content filter of the editor. In order to fix this issue you have two options. First upgrade to the latest version of the control (http://www.telerik.com/help/aspnet-ajax/upgrade_to_a_newer_version_of_radeditor_for_moss.html), which now is 5.7.2 and the second one is to disable the content filters. In order to disable the filters you need to modify the respective ConfigFile.xml or ListConfigFile.xml, which are located in the /Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder.
    For example add the following code:
    <property name="ContentFilters">RemoveScripts,MakeUrlsAbsolute,FixUlBoldItalic,FixEnclosingP,IECleanAnchors,MozEmStrong,ConvertFontToSpan,IndentHTMLContent</property>

    If you decide to disable all the content filters you can add:
    <property name="ContentFilters">None</property>



    Best wishes,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.

  3. Thomas
    Thomas avatar
    7 posts
    Member since:
    Apr 2010

    Posted 06 May 2010 Link to this post

    Hi,

    We have upgraded to RadEditor 5.7.1 (couldn't find 5.7.2), and we still experience the same issues. We also have tried the other option, removing ConvertToXhtml in the ContentFilters property with no success. We also tried to set it to None, but that did not help.

    Any ideas?

    We also managed to reproduced this error in your demopage (http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx) From step 1 to 9 in list below:

    Here is how to reproduce the error (but in the demopage we are not able to save the content (step 10)).

    1. Insert to characters (AA)
    2. Mark the to letters
    3. Change the Font to Courier New
        - The html will now look like this: <span style="font-family: courier new;">AA</span>
    4. Place the cursor between the to letters
    5. Press Enter button
    6. Click the Bullet List button
    7. Switch to HTML view
        - The hmtl code now is invalid:  

    <span style="font-family: courier new;">
    <ul>
        <li><span style="font-family: courier new;">A
        <li>A</li>
        </span></li>
        <li></li>
    </ul>
    </span>

    8. Then switch back to Design view
    9. Now you can see that an extra Bullet appears in the textfield
    10. Save the page, and an extra bullet will appear each time we save.

    Another issue. Try these steps (also in the demopage):
    1. Insert to characters (AA)
    2. Place the cursor between the to letters
    3. Press Enter button
    4. Click the Bullet List button
    5. Switch to HTML view
        - There is now a blank <LI> element
    6. Then switch back to Design view
    7. Now you can see that an extra Bullet appears in the textfield

    Another issue. Try these steps (also in the demopage):
    1. Insert to characters (AA)
    2. Mark the to letters
    3. Click the Bold button
    4. Place the cursor between the to letters
    5. Press Enter button
    6. Click the Bullet List button
    7. Switch to HTML view
        - Look at the hmtl code. It shouldn't be like this.  

  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 10 May 2010 Link to this post

    Hello Thomas,

    Thank you for the provided information. Indeed I was able to reproduce the issues, so I logged it in our bug-tracking system. I also created a pits item so you will be able to be notified when the issues are fixed. You can follow the PITS Issue by its ID: 2091

    500 Telerik points go to your account.

    Kind regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Thomas
    Thomas avatar
    7 posts
    Member since:
    Apr 2010

    Posted 10 May 2010 Link to this post

    Great!

    Do you have any idea when we can expect this bug to be fixed? Our customer is not happy with this error...

    Thomas
  6. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 11 May 2010 Link to this post

    Hi Thomas,

    Unfortunately I can not provide you with an exact estimation of when the issue will be fixed. However it will be done for the next official release, which is scheduled for the begging of July.

    Greetings,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. Thomas
    Thomas avatar
    7 posts
    Member since:
    Apr 2010

    Posted 13 May 2010 Link to this post

    Regarding the issue with the extra bullet we found a workaround. If we remove ConvertFontToSpan in the ConfigFile.xml (ContentFilters), this is issue disappears. So maybe there is a bug somewhere in that fix.

    We also had some other issues with the bullet lists. An extra vertical space was added between the bullet points when we switched between design and html view. The workaround for this issue was to remove the IndentHTMLContent from the ContentFilters in ConfigFile.xml.

    A third issue we have with bulleted points is when you save or switch between design and html view. If you add a bulleted list in the RadEditor, fill one bullet point with text and press Enter button an extra bullet point appears. Fair enough, if that is what you want. But if you save your text in this state, one or two extra paragraphs (<p>&nsbp</p>) will be inserted beneath the bullet point each time you save. This issue was solved when we removed CovertToXhtml from the ContenFilters property in the ConfigFile.xml.

    It looks like the issue with all this things, happens when we either Save og Switch between the to modes. It may be the convertion to html that makes this strange behavior.
  8. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 13 May 2010 Link to this post

    Hi Thomas,

    The problem is that the insert list command generates non XHTML compliant code, so when you save or toggle between modes the RadEditor's filters are trying to fix the content. This is why when you disable the filters there are no extra bullets or lines. So unfortunately at this point the temporary solution is the turn the filters off.

    Regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top