Bullet behavior when selecting all text

6 posts, 0 answers
  1. Aaron
    Aaron avatar
    18 posts
    Member since:
    Nov 2012

    Posted 14 Jan Link to this post

    Kendo: v2016.1.112
    OS: Windows 10
    Browser: Google Chrome (latest: 47.0.2526.111)

    There appears to be some quirky behavior with the bullet feature.  If you have some lines of text that are separated by pressing enter (not shift enter), and then do a select all (either from right click context menu or ctrl+A) and then press the bullet formatting button, only the last line will get a bullet.  This behavior is different than selecting all of the text and pressing the bullet formatting button.

    This can be repro-ed on the demo page for the editor control

  2. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 18 Jan Link to this post

    Hello Aaron,

    I could not reproduce the problem via Ctrl + A / Insert Unordered list. Here is a video of what I tried. Can you please elaborate?

    Regards,
    Alex Gyoshev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Kendo UI is VS 2017 Ready
  4. Aaron
    Aaron avatar
    18 posts
    Member since:
    Nov 2012

    Posted 19 Jan Link to this post

    Here is a video of the behavior in Chrome: http://screencast.com/t/Oxajj0lQkbK

    Also, a video of the behavior in Firefox: http://screencast.com/t/hooHS8hTRPT

    I am using enter for the line breaks.  Hopefully that will help you with the repro.

  5. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 21 Jan Link to this post

    Hello Aaron,

    We have reproduced the issue. It appears that it does not happen after Ctrl+A, only when the context menu "Select All" is clicked -- but either way, we have logged this for fixing.

    Regards,
    Alex Gyoshev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  6. Aaron
    Aaron avatar
    18 posts
    Member since:
    Nov 2012

    Posted 25 Jan Link to this post

    It appears that it does not happen after Ctrl+A

    Hi, I have created another screen capture where I use Ctrl+A and I get the same behavior as when I use the context menu to "Select All".  Not sure if the solution to fix this is the same in both cases, but wanted to bring it to your attention.

    http://screencast.com/t/g8lYbTUG

  7. Alex Gyoshev
    Admin
    Alex Gyoshev avatar
    2500 posts

    Posted 28 Jan Link to this post

    Hello Aaron,

    Thank you for providing this.

    Regards,
    Alex Gyoshev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
Back to Top
Kendo UI is VS 2017 Ready