Bug: ComboBox with contains filter on select element

2 posts, 0 answers
  1. Raphael
    Raphael avatar
    2 posts
    Member since:
    Jan 2013

    Posted 18 Dec 2013 Link to this post

    Hy 

    I have created a small example (sorry for coping your source): 
    http://jsfiddle.net/jT4tv/

    Enter in the combobox an arbitary value that does not exists as an option. Then use the tab control to change the focus (or click somewhere else on the page). Now set the focus in the tab control again and delete all content with the backspace key. The combobox will then reopen and your arbitary value (in my case abababa) is set in the text field again! Now the user has to delete the value again. Sometimes the value even appears multiple times, even  much later! 

    I could not reproduce the issue with server filtering (for small data sets we use inline selects to reduce the number of requests) or when no filter is set.

    I would appreciate it when you could investigate this issue.

    Kind Regards

  2. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3707 posts

    Posted 19 Dec 2013 Link to this post

    Hello Raphael,

    Thank you for drawing our attention to this problem. We addressed the issue and the fix will be available in the next internal build of Kendo UI. As a token of gratitude I updated your Telerik points.

    Regards,
    Georgi Krustev
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Kendo UI is VS 2017 Ready
Back to Top