Broken Image Link

11 posts, 0 answers
  1. Neil
    Neil avatar
    7 posts
    Member since:
    Apr 2008

    Posted 24 Sep 2009 Link to this post

    When I attempt to use the CAPTCHA functionality, we get a broken image link above the field.  any suggestions?

    thanks.

  2. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 28 Sep 2009 Link to this post

    Hello Neil,

    The RadCaptcha image is served by an httpHandler that needs to be registered in the web.config file. These lines need to be pasted in the configuration file:

     <httpHandlers>   
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />   
    </httpHandlers>   
      
    <handlers>   
         <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />   
    </handlers>  

    If this does not solve the problem, please provide additional information about the issue, and send us a running sample where we can observe the problem.

    Regards,
    Pero
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Will
    Will avatar
    30 posts
    Member since:
    Aug 2008

    Posted 19 Oct 2009 Link to this post

    Hey Pero,

    The documentation has different information, which you may want to update.  The design time "Enable RadCaptcha Http Handler" functionality is broken, as it returns the following error:

    Error invoking 'Enable RadCaptch Http Handler'. Details: Could not find method 'AddHandlers'.

    Also, the Telerik <handlers> entries do not automatically create <location> overrides (or the equivalent) for themselves.  If an application has enabled ASP.NET Authroization, and has disabled access to everything by default, none of the Telerik <handlers> will operate.  I would consider this a bug.  The work-around is to manualy add <location> overrides for each Telerik <handlers> <add>.

    Thanks,
    Bill
  5. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 21 Oct 2009 Link to this post

    Hi Bill,

    You can use both of the declarations (the one in the online documentation and the one provided in the previous response), they point to the same httpHandler. I recommended using the previously mentioned declarations because the same handler is used by the RadScriptManager and it is possible that a conflict may arise from using both of the declarations. We will update the documentation with the httpHandler above-mentioned declarations.

    Thank you for pointing out both issues - the problem with the design time "Enable RadCaptcha Http Handler" functionality, and the issue with adding <location> declarations automatically. We are logging them in our ToDo list and will do our best to address them in one of our future releases.


    Best wishes,
    Pero
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Ryan
    Ryan avatar
    2 posts
    Member since:
    Apr 2009

    Posted 08 Feb 2010 Link to this post

    Pero,

    I use forms authentication but have a password reset page that I allow * using the <location> section and override the authorization. I therefore need to add the handler declarations for the WebResource.axd in both sections of the Web.config. This produces a runtime error as I now have duplicate entries.

    What is the best way to overcome this, as I need both declarations.

    Kind regards,

    Ryan
  7. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 10 Feb 2010 Link to this post

    Hello Ryan,

    You should leave only the following declaration for the RadCaptcha HttpHandler:

    <httpHandlers>  
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />  
    </httpHandlers>  
       
    <handlers>  
         <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />  
    </handlers>

    Besides giving access to the password reset page to all users, you should also allow access to the Telerik.Web.UI.WebResource.axd. The code should look like the following:

    <location path="Telerik.Web.UI.WebResource.axd">
      <system.web>
        <authorization>
          <allow users="*"/>
        </authorization>
      </system.web>
    </location>



    Greetings,
    Pero
    the Telerik team

    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
    Follow the status of features or bugs in PITS and vote for them to affect their priority.
  8. Kenn
    Kenn avatar
    3 posts
    Member since:
    Oct 2006

    Posted 17 May 2010 Link to this post

    Pero, thank you for the web.config settings.   I had this same issue on a form.   My site required authentication, but not the page where the captcha existed!   You saved me a lot of time!   Thanks again.
  9. Haris
    Haris avatar
    3 posts
    Member since:
    Aug 2010

    Posted 25 Aug 2010 Link to this post

    Hi,

    I tried all these solutions, but still, captcha is a broken image.

    Please help...
  10. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 26 Aug 2010 Link to this post

    Hello Haris,

    Could you please provide more information about the problem? It would help us a lot if you can answer to any of the following:
    • Is your local server environment, a WebGarden or WebFarm?
    • If the above is true, have you configured your environment to use out of process Session?
    • Have you correctly registered the HttpHandlers that serve the CaptchaImage in your configuration file? Please note that you must register the httpHandler in both <system.web> ------> <httpHandlers>, and <system.webServer> -------> <handlers>. The first one is for earlier versions of IIS, and the second for later.
    • Are you using any kind of user authentication and authorization in your application? If yes, please make sure you have allowed access to the RadCaptcha httpHandler, to all users.
    • Which version of RadControls for ASP.NET AJAX are you using?
    • Please provide a screenshot of how the Captcha looks.

    Kind regards,
    Pero
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Haris
    Haris avatar
    3 posts
    Member since:
    Aug 2010

    Posted 26 Aug 2010 Link to this post

    Hi Pero,

    I tried all that you suggested above. I registerd the handler.  I'm using the basic Windows 7 IIS. I gave the permission to the radcaptcha handler. Captcha is still a broken image.
    The version is: 2009.02.0701.35.

    Thanks.
  12. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 27 Aug 2010 Link to this post

    Hello Haris,

    This is the version of our components, where the RadCaptcha control was released for the first time. This version does not support WebFarm and WebGarden scenarios. Could you please update the RadCaptcha to the latest version available and see if the problem persists?

    Regards,
    Pero
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017