Breadcrumbs not loading the first time

4 posts, 0 answers
  1. Noel
    Noel avatar
    10 posts
    Member since:
    Jan 2011

    Posted 22 Nov 2011 Link to this post

    Hi Telerik,

    I've a radSiteMap which is coupled to a RadTree, based on where the path I select on the RadTree, the siteMap(BreadCrumbs) shows up. It works fine.. But unfortunately, the first time, the breadCrumbs load up, the text of the breadcrumbs is not visible, only the separators are there. As soon as I move some control around, it becomes visible.. 
    Is there any way to bring it up the first time itself so that it doesnt leave an awkward gap in the breadcrumbs area?

    Thanks and Regards,
    toptorps
  2. Plamen
    Admin
    Plamen avatar
    2734 posts

    Posted 25 Nov 2011 Link to this post

    Hi Noel,

     
    It is not very clear to me what is your exact scenario. Would you please provide some code or some live url that will help us reproduce or at least observe the issue?

    Regards,
    Plamen Zdravkov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Noel
    Noel avatar
    10 posts
    Member since:
    Jan 2011

    Posted 01 Dec 2011 Link to this post

    HI Plamen,

    I tried creating a dummy project, but its not reproducible there. 
    The situation is like this:
    There are different panels on the page. Assume, there is a browseTree, breadcrumb panel and a Product info panel.
    When the Product info panel loads, the corresponding breadcrumb should also appear. Now, it works fine usually..
    WHen I deploy my service on IIS, and access it from another machine, the first time, I navigate to a product on the browse tree and click it, the product info loads, but the corresponding bread crumbs text is missing. Only the chevrons appear. As soon as I click on a control or try to resize it, the breadcrumb text appears.
    This problem doesnt come if I access the web site from the same system. 
    Only if its a different system and that too the first time.

    Thanks,
    Noel
  5. Dimitar Terziev
    Admin
    Dimitar Terziev avatar
    1266 posts

    Posted 06 Dec 2011 Link to this post

    Hello Noel,

    The provided information is insufficient to determine what is causing this strange behavior. Please provide a live URL to your application so we could examine the problem locally

    All the best,
    Dimitar Terziev
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top