Avoid the import of a specific css file

4 posts, 1 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 24 Apr 2009 Link to this post

    Hi,

    my problem is the following.
    I allow my customer to change the look of the site's masterpage.
    For this I provide (beside others) a "frames.css" this file has a lot of divs with large dimensions (1000x900 and so).
    And those divs sometimes have "content" (Background images).
    The result - when I use the CSS dropdown in RadEditor it almost becomes unusable due to the fact that it displays previews - 1000px large.

    It is a single css file which holds those nasty things. Is there an easy way to tell RadEditor - pleas don't use frames.css.

    Regards

    Manfred
  2. Answer
    Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 24 Apr 2009 Link to this post

    Hi ManniAT,

    Please, see this help article: CSS Styles. You can also specify your own css file to load in the RadEditor's Apply Class dropdown by setting the CssFiles property (see External Css Files)


    Greetings,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 24 Apr 2009 Link to this post

    Hi Rumen,

    thank your for this extreme fast response (new telerik record in fast support :)).
    Suggestion one does not really help - to much styles used :)

    The second tip solved my problem.
    And brings up an other one.
    This is not stopping me - I just want to point it out.

    The easiest way to implement the things seemed to be the tools file.
    This works - BUT it does not work with the ToolProviderID mechanism.
    So my first editor has the correct settings (uses the wanted css) - but the others (using ToolProviderID) are showing up the full set of CSS styles.
    I could solve this by setting <cssfile> directly at those editors - I just wanted to notice that this setting is not working with ToolProviderID.

    Thank you

    Manfred
  5. Tervel
    Admin
    Tervel avatar
    1337 posts

    Posted 27 Apr 2009 Link to this post

    Hello ManniAT,

    Thank you for pointing this issue - we logged it for fixing in the future.

    Best regards,
    Tervel
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top