Application crash when moving diagram item

6 posts, 1 answers
  1. Deepak Shakya
    Deepak Shakya avatar
    118 posts
    Member since:
    Aug 2007

    Posted 01 Jul 2013 Link to this post

    Hi,

    I have got a problem. When I move any of the dropped diagram item, I get the white screen and the program stops responding.

    • I can drag and drop the item from list to Diagram without any issue.
    • I can double click on it to get the edit template
    • As soon as I move the item, the program dies.
    • The DiagramItem uses StyleSelector to get shapes on the type of data passed.

    Has been any changes relating to this or has this issue been reported by anyone? This was all working fine without a glitch before.
  2. Deepak Shakya
    Deepak Shakya avatar
    118 posts
    Member since:
    Aug 2007

    Posted 01 Jul 2013 Link to this post

    The error attached.
  3. DevCraft banner
  4. Egemen
    Egemen avatar
    34 posts
    Member since:
    Apr 2012

    Posted 01 Jul 2013 Link to this post

    Hi,

    Not really... I had to install the latest version of Telerik on my secondly laptop which use windows 7 pro. And it works fine but My first laptop works on Windows Home Premium and despite my effort, uninstall and install after, i cant resolve this problem.

    Regards
  5. Deepak Shakya
    Deepak Shakya avatar
    118 posts
    Member since:
    Aug 2007

    Posted 01 Jul 2013 Link to this post

    Hi,

    I have tried uninstalling the Q2 Release and just using the Q1 assemblies in Reference. The result is the same. I have re-installed it and run it again with Q2 reference. The result is the same again.

    I have prepared a sample project available from my SkyDrive and also has a companion video to show what happens at my end. I cannot explain why this is an issue.

    I am running 64 bit Windows 7 Enterprise with VS 2012 and Q2 2013 Telerik Release.

    Any help is highly appreciated.
  6. Answer
    Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1183 posts

    Posted 03 Jul 2013 Link to this post

    Hello,

    I already answered to this question in your ticket. However, I will post the same answer here, so that others form the community can find it.

    Thank you for providing us with detailed information about your implementation. The screen cast helped us to understand your scenario and the steps to reproduced the issue.

    However, I tested your project with our latest official release and the code works as expected. I could not reproduce your issue. Can you please elaborate more on the version of  the dlls that you use. Can you please try to reproduce the behavior with out official release.

    I am looking forward to hearing from you.

    Regards,
    Pavel R. Pavlov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  7. Deepak Shakya
    Deepak Shakya avatar
    118 posts
    Member since:
    Aug 2007

    Posted 05 Jul 2013 Link to this post

    Hi Pavel,

    First, thanks for getting back to me through ticket support. I am writing replying here for other community members to know what happened with my issue.
    • I checked and double checked my solution and I have been using the latest official release of the Telerik Controls.
    • Then I tried this - I ran the solution in my laptop where RadControls were not installed by using just the same DLLs that required to run the project
    • The project ran fine and no blank screen. (Amazing!)
    • So I went back to my PC and removed all Telerik products included in my DevCraft and re-installed only the Silverlight and WPF controls
    • Ran the project
    • Voila. The problem is gone.

    I can now use the RadDiagrams items as before. I can drag the items and the program does not crash. I have no idea why or how this happened. I am just glad that my application is running again. Thanks for your help.
Back to Top
DevCraft banner