Ajax not Working in Sharepoint

4 posts, 0 answers
  1. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 16 Sep 2011 Link to this post

    Hello,

         I have a aspx page in Sharepoint with some buttons, labels e.t.c. I am using radajaxmanager for ajax operation. But ajax will not work in this page. if I creating ordinary wesite ajax will work properly. But  didnt work  as a sharepoint site. Please give the solution for this problem.
  2. Maria Ilieva
    Admin
    Maria Ilieva avatar
    4017 posts

    Posted 20 Sep 2011 Link to this post

    Hi Velkumar,

    Could you please ensure that you have ScriptManager on the very top of the MasterPage of the application or in the beginning of the WebPart where the ajax functionality is used. 

    Greetings,
    Maria Ilieva
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now

  3. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 20 Sep 2011 Link to this post

    Hello,
             I have the radScriptmanager in the aspxpage.
  4. Maria Ilieva
    Admin
    Maria Ilieva avatar
    4017 posts

    Posted 21 Sep 2011 Link to this post

    Hello Velkumar,

    Please refer to the following help topic which elaborates on adding ajax functionality in SP. Ensure that you are using the correct approach for achieving the required functionality.
    Also please test the application by using regular asp UpdatePanel instead of RadAjax and verify of the ajax request works as expected in this case.

    Greetings,
    Maria Ilieva
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top