AJAX not working / Full Post backs

3 posts, 0 answers
  1. Taiseer
    Taiseer avatar
    37 posts
    Member since:
    Oct 2007

    Posted 10 Nov 2011 Link to this post

    My problem is pretty simple but I really can not figure how to solve it, the scheduler keeps doing full post backs on the page while I'm changing the dates, opening the advanced form, etc...

    Please provide me with attached working example built on 4.0. I been trying to solve this silly issue for more than three hours and tried to put the script manager in Master page, etc... but nothing worked for me.

    I'm using Telerik 2011 Q2 and I have the scheduler in the page as below:
    <asp:Content ID="Content1" ContentPlaceHolderID="MainContentPlaceHolder" runat="server">
        <rad:RadScriptManager runat="server" ID="RadScriptManager1" />
        <rad:RadAjaxManager ID="RadAjaxManager1" runat="server" EnableAJAX="true" DefaultLoadingPanelID="RadAjaxLoadingPanel1">
            <ajaxsettings>
                    <rad:AjaxSetting AjaxControlID="RadScheduler1">
                        <UpdatedControls>
                            <rad:AjaxUpdatedControl ControlID="RadScheduler1" />
                        </UpdatedControls>
                    </rad:AjaxSetting>
                </ajaxsettings>
        </rad:RadAjaxManager>
        <div id="dvMain">
            <rad:RadScheduler ID="RadScheduler1" runat="server" Skin="Windows7" DayStartTime="08:00:00"
                DayEndTime="18:00:00" DataKeyField="ID" DataSubjectField="Subject" DataStartField="Start"
                DataEndField="End">
            </rad:RadScheduler>
        </div>
        <rad:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" />
    </asp:Content>

    The HTML in master page as below:
    <head runat="server">
        <title>Home</title>
    </head>
    <body>
        <form id="frmMaster" runat="server">
        <div>
            <asp:ContentPlaceHolder ID="MainContentPlaceHolder" runat="server">
            </asp:ContentPlaceHolder>
        </div>
        </form>
    </body>
    </html>

    waiting your forthcoming reply.
  2. Taiseer
    Taiseer avatar
    37 posts
    Member since:
    Oct 2007

    Posted 13 Nov 2011 Link to this post

    Any update on the below? I tried the same without Master page and still it is doing full post backs!! I need third eye please, Might forget something during the AJAX configuration.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Taiseer
    Taiseer avatar
    37 posts
    Member since:
    Oct 2007

    Posted 13 Nov 2011 Link to this post

    It has been solved, i was missing the Skin property from AjaxLoadingPanel !!
    <rad:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Skin="Windows7" />

Back to Top