problem with RadNumericTextBox

2 posts, 1 answers
  1. Paul Evers
    Paul Evers avatar
    52 posts
    Member since:
    Oct 2011

    Posted 04 Apr 2012 Link to this post

    I am using RadNumericTextBox with skin Metro

    The style is changed to:
    .riDisplay
    {
        border-width: 1px !important;
        color: #6384B5 !important;
        border-color: #A8A8A8 !important;
        *height: auto !important;
    }
    .InputField
    {
        width: 85px !important;
    }

    When I display this in IE9 (or Chrome, FireFox) this will be displayed correct.
    When I turn on compatibilitymode in IE9 the textbox is messed up.
    When I select the rendered inputfieldbox the used style looks different. (see attached picture): the inputfieldbox is wider than the displaybox.
    The height of the displaybox was also larger but I could fix that by adding the style *heightauto !important; 

    How can I fix the width of the inputfieldbox?

    Paul

  2. Answer
    jumpstart
    jumpstart avatar
    479 posts
    Member since:
    Nov 2011

    Posted 06 Apr 2012 Link to this post

    Paul:

    You did not specify what version of the RadControls that you're using here. But, if you're using the most current 2012.1.215.40 version, this could have something to do with the newly introduced SingleInputRendering functionality.

    Take a look at the Input/First Look online demo and toggle the "EnableSingleInputRendering" check box. The property is set to true by default in the new build. You can try setting it to false to see if this effects your display.

    Hope this helps!
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top