5.2.2 Stripping font tags

9 posts, 0 answers
  1. Michael Stone
    Michael Stone avatar
    25 posts
    Member since:
    Sep 2006

    Posted 29 Sep 2008 Link to this post

    I upgraded from 4.5.3 to 5.2.2 and now I have a problem when editing the description field of a task list.

    If I change the font size of some text and then save the entry, the font tags (I guess, in 5.2.2 it is now a span with a style set) are stripped.

    By default, the description fields of a task list are Rich Text (not enhanced rich text).

    I used U2U's CAML builder to view the contents directly and confirmed that the tags are being stripped before the values are saved into the field.

    If I set the description field to enhanced rich text, the problem goes away.  I thought this might be a SharePoint problem but 4.5.3 worked just fine.  I did notice that 4.5.3 surrounds the text with <font> tags and 5.2.2 with <span style='xyz'>

    Is SP stripping style tags on non-enhanced Rich Text fields?
  2. George
    Admin
    George avatar
    859 posts

    Posted 30 Sep 2008 Link to this post

    Hi Michael,

    Note that, when the description field is Rich text is supports only Bold, italics and text alignment - please review the attached screenshot. Due to this, the spans are stripped. Please set the field to be Enhanced rich text.

    I hope this helps.

    Sincerely,
    George
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.

  3. Michael Stone
    Michael Stone avatar
    25 posts
    Member since:
    Sep 2006

    Posted 30 Sep 2008 Link to this post

    Why did version 4.5.3 work just fine with non-enhanced rich text?
  4. George
    Admin
    George avatar
    859 posts

    Posted 01 Oct 2008 Link to this post

    Hi Michael,

    In RadEditor 4.5.3 in order to underline some content the editor uses U tags, which when using a Rich text field are not stripped. However, the new editor has an improved XHTML compliant filters and in order to produce XHTML compliant content inserts SPANs instead of Us. This is the reason for the observed behavior.

    Sincerely,
    George
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Andreas
    Andreas avatar
    6 posts
    Member since:
    Nov 2007

    Posted 13 Oct 2008 Link to this post

    I have also tried to impliment the new version 5.2.2 and 5.2.3 and list data that is stored in non enhanced rich text is stripped.  How can this be the "design"?  Now the RadEditor for moss is USELESS for most entries, unless Enhanced Rich text is used, or for page content.  I am very displeased that an update to a tool, which was working has drastically changed and is marked as "works as designed."

    When can we expect a fix, this feature has to work again before we can start to use AJAX rad editor in a productive environment.  Also, this was one of the major reasons we purchased the product suite.

    If things are no longer supported, such as colour, font size, etc. Why are the buttons still shown?
  6. Tom.S
    Tom.S avatar
    17 posts
    Member since:
    Apr 2007

    Posted 13 Oct 2008 Link to this post

    Massive issue, get this fixed. The RAD editor is supposed to at least include the same features as the OOTB SharePoint rich text editor.

    Sigh
  7. George
    Admin
    George avatar
    859 posts

    Posted 14 Oct 2008 Link to this post

    Hi guys,

    I logged this problem in our ToDo list and we will do our best to address it for one of the next major updates of the control. In the meantime, please set the column to be Enhanced Rich Text.


    Kind regards,
    George
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  8. Andreas
    Andreas avatar
    6 posts
    Member since:
    Nov 2007

    Posted 14 Oct 2008 Link to this post

    Thanks for generating the todo, but I wanted to point out that, we cannot simply change all of our columns to enhanced rich text, this change affects thousands of lists in our farm.  So I would not relate to clients as a fix or a holdover.
  9. George
    Admin
    George avatar
    859 posts

    Posted 15 Oct 2008 Link to this post

    Hi Andreas,

    Excuse us for the inconvenience. Unfortunately, currently the only solution is to set the column's type to be Enhanced Rich Text. We will do our best to fix this problem as soon as possible.

    Regards,
    George
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top