Error loading RadChart image

Thread is closed for posting
6 posts, 1 answers
  1. Alex Tushinsky
    Alex Tushinsky avatar
    52 posts
    Member since:
    Feb 2006

    Posted 25 Nov 2009 Link to this post

    I am using the Telerik RadChart (Q3 2009) with a DotNetNuke installation (5.1.4), in a custom module.  Everything has been working fine, but today I noticed that I'm getting a "Error loading RadChart Image" error message on my module.  I have both a development and a prod environment.  Development is a Windows 2008 R2 server (IIS 7.5), and Prod is a Windows 2003 (IIS 6) box.  The web.config files are identical, and everything works fine in dev, but not in prod (as is always the case).

    In <system.webserver> <handlers>, I have:

    <add name="ChartImage_axd" verb="*" preCondition="integratedMode" path="../../ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" />

    and also tried <add name="ChartImage_axd" verb="*" preCondition="integratedMode" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" />  

    and in <system.web> I have:

    <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />

    In my code, I also have a line that reads: RadChart1.HttpHandlerUrl = ResolveUrl("ChartImage.axd")

    and I've also tried setting UseSession to false, and setting a temporary folder.  This produced exactly the same results, however, I did see the chart images being created in my temp folder.

    I'm not sure what I'm missing.. any help is greatly appreciated!





  2. Answer
    Bartholomeo Rocca
    Bartholomeo Rocca avatar
    247 posts
    Member since:
    May 2006

    Posted 27 Nov 2009 Link to this post

    Hello Alex,

    This certainly looks like a problem related to incorrect configuration of the ChartHttpHandler in the web.config -- I noticed that in your system.webserver / handlers section the path attribute looks like path="../../ChartImage.axd" while in the system.web it looks like path="ChartImage.axd".

    I believe it should be declared in the same way in both sections as it seems your development environment uses IIS7 (webserver section configuration) while your production environment uses IIS6 (system.web section configuration)

     
    Greetings,
    Bart.







  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Alex Tushinsky
    Alex Tushinsky avatar
    52 posts
    Member since:
    Feb 2006

    Posted 30 Nov 2009 Link to this post

    As it turns out, there were two problems.  One was the difference in the paths between <system.web> and <system.webserver> of web.config, and the second was a re-direct configuration setup within DotNetNuke.  As a result, chartimage.axd never had a chance to be loaded.  Straightened out both issues, and now everything works as expected!
  5. Joseph
    Joseph avatar
    29 posts
    Member since:
    Sep 2007

    Posted 15 Jun 2010 Link to this post

    Hi,

    I am having the same issue with the RadChart that opens in a RadWindow inside DNN.  I was able to update my web.config file, but I am still having the issue of the chart not showing.

    Alex - in your post you mentioned "the second was a re-direct configuration setup within DotNetNuke"

    Can you tell me what configuration setting you had to change?

    Thanks,
    Joe
  6. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 18 Jun 2010 Link to this post

    Hello Joe,

    You can find this discussed in this forum thread.

    Kind regards,
    Ves
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Chakrapani
    Chakrapani avatar
    7 posts
    Member since:
    Aug 2011

    Posted 07 Mar 2012 Link to this post

    Hi im also facing sme problem and my web.config handlers are listed below.

       <httpHandlers>     
          <add verb="*" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />
          <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
        </httpHandlers>   
      </system.web>
      <system.webServer>

     

     

     

Back to Top
UI for ASP.NET Ajax is Ready for VS 2017