Margin/padding inside plot area

7 posts, 0 answers
  1. Markus
    Markus avatar
    13 posts
    Member since:
    Sep 2013

    Posted 08 Jan 2014 Link to this post

    Hi,


    I'd like to have fixed y/x-axis 0 to 1. Values above and below don't make sense.

    There are values exactly at (0,0.5) and by using a point series they are only partially within the plotable area

    and become very hard to select. Is there a margin/padding property I can set?

    Changing the axis minimum helps, but then my axis annotation don't make sense anymore.



    Markus

  2. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1183 posts

    Posted 13 Jan 2014 Link to this post

    Hello Markus,

    I am happy to inform you that there is straightforward approach achieving your requirement. If you are using the CategoricalAxis you can use the PlotMode property. In your particular case you can set it to OnTicksPadded.

    Please give this approach a try and let us know if you need any further assistance.

    Regards,
    Pavel R. Pavlov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WPF.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. UI for WPF is Visual Studio 2017 Ready
  4. Markus
    Markus avatar
    13 posts
    Member since:
    Sep 2013

    Posted 13 Jan 2014 Link to this post

    Hi,

    Unfortunately I'm using 2 linear axis since my values are continuous between 0 and 1.
    Any solution for this?

    Thanks,
    Markus
  5. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1183 posts

    Posted 14 Jan 2014 Link to this post

    Hello Markus,

    Could you please try the ClipToPlotArea property of the ScatterPointSeries in your particular case?

    Regards,
    Pavel R. Pavlov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WPF.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  6. Markus
    Markus avatar
    13 posts
    Member since:
    Sep 2013

    Posted 14 Jan 2014 Link to this post

    I see the points, but they are outside of the plotting area. I guess this is expected.


    Any idea on how I can increase the plotting area and still keep my axis between 0 and 1?

  7. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1183 posts

    Posted 16 Jan 2014 Link to this post

    Hi Markus,

    The RadChartView control is designed to precisely render the points in its plot area. The best approach that we suggest to achieve your requirement is to use the already suggested property.

    However, if you insist to change that layout you can try setting margins to your Axes. By doing so both axes will not be crossing one over another, but your scenario will be achieved. You can use similar to this snippet:

    <telerik:RadCartesianChart.HorizontalAxis>
        <telerik:LinearAxis Margin="0 10 0 0"/>
    </telerik:RadCartesianChart.HorizontalAxis>
    <telerik:RadCartesianChart.VerticalAxis>
        <telerik:LinearAxis Margin="0 0 10 0"/>
    </telerik:RadCartesianChart.VerticalAxis>
    I hope this is helpful.

    Regards,
    Pavel R. Pavlov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WPF.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  8. Markus
    Markus avatar
    13 posts
    Member since:
    Sep 2013

    Posted 16 Jan 2014 Link to this post

    Works for me!
Back to Top
UI for WPF is Visual Studio 2017 Ready