The time has come for Fiddler to say goodbye to .NET 3.5. Our usage statistics currently show that less than 3% of our users are using .NET 3.5, and so we can no longer justify the effort needed to keep all new Fiddler versions running on .NET 3.5. 

We are still going to keep the most recent (at the time of writing) .NET 3.5 version in the Fiddler installer, and it will be automatically chosen for installation on machines that have no higher version of .NET installed. While you're welcome to keep using it, this version is not going to get updated from this point on. As time passes it is going to get less and less useful, and at some point in the future we will remove it completely. 

So, to sum up, in order to get updates to Fiddler from now on one should have at least .NET 4.0 installed. .NET 4.0 replaces .NET 3.5 as the minimal supported .NET version for Fiddler. 

FiddlerCore 

FiddlerCore will follow suit with Fiddler. The .NET 2.0 and .NET 3.5 builds will remain in the installer but will cease to get updates. The .NET 4.0 framework is going to be the lowest .NET version that will continue to receive FiddlerCore updates. 

Fiddler Add-ons 

At present the vast majority of Fiddler add-ons are compiled against .NET 3.5. They will keep on working on the new versions of Fiddler the same way they work on Fiddler for .NET 4.0 now. We will release .NET 4.0 versions of the add-ons that we maintain since it is now safe to do that. All add on creators are welcome to do that, too, and benefit from the features offered by .NET 4.0. 

In the future we will remove the dependency between the add-ons .NET version and the .NET version Fiddler was built against, thus enabling the add-on authors to use cutting edge .NET features. 


Tsviatko Yovtchev
About the Author

Tsviatko Yovtchev

Tsviatko is the Lead Developer for JustDecompile and Fiddler.

Related Posts

Comments

Comments are disabled in preview mode.