Memory leak

6 posts, 0 answers
  1. dario
    dario avatar
    9 posts
    Member since:
    Dec 2008

    Posted 06 Jun 2011 Link to this post

    I know that is hard to predict what happend, but today my work (one opened .NET 4 assembly)  with JD was ended with huge memory leak by JD.

    Version: Beta 2011.1.603.5
    Windows 7 x64

    Regards.
    Dariusz.
  2. Kaloyan
    Admin
    Kaloyan avatar
    920 posts

    Posted 06 Jun 2011 Link to this post

    Hello Dariusz Tarczynski,

    Can you describe how did you achieve this large memory  consumption. Have you navigated by treeview/codeviewer or through the Find Usage?

    Greetings,
    Kaloyan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  3. DevCraft banner
  4. dario
    dario avatar
    9 posts
    Member since:
    Dec 2008

    Posted 06 Jun 2011 Link to this post

    Hi,
    I can reproduce it :-) It's by navigation in tree, and clickin on InitializeComponent (standard winforms method). The assembly Im decompiling is a Winforms application written in .NET 4, c#.
  5. Kaloyan
    Admin
    Kaloyan avatar
    920 posts

    Posted 07 Jun 2011 Link to this post

    Hi Dariusz Tarczynski,

    Just a clarification - which version of the JD are you currently using and would you be so kind to send us or pinpoint the exact type/member that leads to the huge memory consumption?

    Greetings,
    Kaloyan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  6. dario
    dario avatar
    9 posts
    Member since:
    Dec 2008

    Posted 08 Jun 2011 Link to this post

    It's when I have tons of controls in InitializeComponent method(s), so when I jumping into these methods, the memory consumptions is rising.
    If it's hard to reproduce for you, please to contact me, I don't wont to put this assembly on public.

    Regards
    Darek
  7. Kaloyan
    Admin
    Kaloyan avatar
    920 posts

    Posted 13 Jun 2011 Link to this post

    Hello dario,

    Thank you once again for you assistance. I will appreciate if you send the problematic assembly to my email: kaloyan.manev@telerik.com.

    Greetings,
    Kaloyan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

Back to Top
DevCraft banner