Just Decompile locks up when opening Windows 8.1 xaml assembly

8 posts, 0 answers
  1. Anthony
    Anthony avatar
    5 posts
    Member since:
    Feb 2012

    Posted 28 Oct 2013 Link to this post

    I created a default GridApp project with VS2013, and tried to open it with JustDecompile (the lastest version)

    but when I do it hangs at startup.

    I tried to attach the exe here, but am not allowed, unfortunately.

    After trying to open it, I fail to open JustDecompile every time until I delete the file

    C:\Users\Tony\AppData\Roaming\JustDecompile\AssemblyLists\DefaultAssemblyList.xml

    Hope this info helps.

  2. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 31 Oct 2013 Link to this post

    Hi Anthony,

    Many thanks for the bug report. We've reproduced and fixed it. We are testing the fix right now and we'll have a new version with the fix soon. If you're fine waiting a bit, this'll be great. Else please let us know if you need an improved version sooner.

    Also as a sign of our gratitude for helping us find this issue, I've updated your telerik points. You can review them in your account at telerik.com.
     
    Regards,
    Vladi
    Telerik
    Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
  3. DevCraft banner
  4. Larry
    Larry avatar
    22 posts
    Member since:
    Jun 2009

    Posted 04 Nov 2013 Link to this post

    Once this is working with 8.1 - will it be able to decompile the xbf files so we can see the XAML?
  5. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 06 Nov 2013 Link to this post

    Hi Larry,

    We've released a fix in our latest version (v. 2013.3.1029.1). Please update and let us know if you stumble upon the same issue again.

    As for the XBF files, for now it seems that this might be not possible. But we'll investigate and will follow up.

    Kind regards,
    Vladi
    Telerik
    Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
  6. Dirk
    Dirk avatar
    43 posts
    Member since:
    May 2011

    Posted 07 Nov 2013 Link to this post

    Sorry Vladi,
    the problem is still there.
    Version 2013.3.1029.1

    If I open a Windows Store App exe file with JustDecompile then I get a progressbar (Loading assemblies ...), the screen itself is disabled and then nothing happens anymore.

    Do you have an old version of JustDecompile?
    Yesterday with the old version I had no problems, but then I've updated and found this posting here.
    I'm just testing some Obfuscator tools.

    Regards
    Dirk
  7. Nikolay G Rusev
    Admin
    Nikolay G Rusev avatar
    44 posts

    Posted 11 Nov 2013 Link to this post

    Hi Dirk,

     Unfortunately we couldn't reproduce the issue. Can you send us the assembly you are trying to open? You can mail it to nikolayg(dot)rusev(at)telerik(dot)com.
    Also, can you give us a bit more details about the problem? Specifically CPU and memory usage of the JustDecompile process.

    Regards,
    Nikolay G Rusev
    Telerik
    Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
  8. Dirk
    Dirk avatar
    43 posts
    Member since:
    May 2011

    Posted 11 Nov 2013 Link to this post

    Hi Nicolay,


    I've found the problem.

    I don't know if you changed something in JustDecompile or if Microsoft changed something.



    You have to start JustDecompile as an Administrator! Then it works.

    Two weeks ago I hadn't still to do this.

    Non WinRT NET 4.5 assemplies can also be opened as a non-administrator.



    But never the less JustDecompile should raise a warning if an assembly couldn't be opened because of some missing rights.

    In the moment JustDecompile just hangs while the progressbar is doing it's never ending Job.



    Regards

    Dirk



  9. Nikolay G Rusev
    Admin
    Nikolay G Rusev avatar
    44 posts

    Posted 14 Nov 2013 Link to this post

    Hi Dirk,

     Glad to hear that you've fixed your problem and thanks for pointing out the issue about the permissions. We'll definitely fix it in some of our forthcoming releases.

    Regards,
    Nikolay G Rusev
    Telerik
    Tell us what you think about JustDecompile. Your opinion matters! You can use our forum, or our JustDecompile UserVoice website for feature requests.
Back to Top
DevCraft banner