All Components

Troubleshooting

This article provides solutions for issues you might encounter while working with the Kendo UI suite for Vue.

Browsers Support

I would like to enable IE 11 support for my Vue app

Cause

Internet Explorer 11 does not offer support for ECMAScript 2015 (ES 6). Therefore, it could not load properly any ES 6 modules.

Solution

You will need to install the babel-polyfill package:

npm install --save "babel-polyfill"

And import in the Vue app:

import 'babel-polyfill'

Vue Specific Syntax

How should I attach the event handlers for the widgets. Using kebab-case does not work e.g.: v-on:data-bound

Cause

The Vue framework imposes a limitation on the custom event emitted in Vue.

Solution

Lower case should be used instead:

<kendo-grid :data-source="localDataSource"
            v-on:databound="onDataBound">
</kendo-grid>

or:

<kendo-grid :data-source="localDataSource"
            @databound="onDataBound">
</kendo-grid>
In this article