Telerik Silverlight Controls in VS 2010 Part 2

43 posts, 0 answers
  1. Jeff Cuscutis
    Jeff Cuscutis avatar
    7 posts
    Member since:
    Nov 2009

    Posted 15 Dec 2009 Link to this post

    I tried the new update and the items are now in the toolbox. I still receive errors however.
    Steps I followed:
    Uninstalled previous radcontrols / Installed new radcontrols

    New Silverlight Application
    Dragged Scheduler onto form successfully
    Built and ran successfully

    Closed app and received an error in designer:

    System.Runtime.Serialization.SerializationException
    Type 'System.Windows.Markup.XamlParseException' in assembly 'System.Windows, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' is not marked as serializable.
       at MS.Internal.Host.Isolation.IsolatedView.get_ViewHandle()
       at MS.Internal.Designer.DesignerPane.LoadDesignerView()

    Closed form, crashed vs2010
    Reopened project, same error in designer

    Removed scheduler from xaml, tried to drag new scheduler to designer but the cursor is not allowing a drop
  2. Jeff Cuscutis
    Jeff Cuscutis avatar
    7 posts
    Member since:
    Nov 2009

    Posted 15 Dec 2009 Link to this post

    Also, the help viewer does not work very well. I have yet to find a page that displays at all without crashing.
  3. Jeff Cuscutis
    Jeff Cuscutis avatar
    7 posts
    Member since:
    Nov 2009

    Posted 15 Dec 2009 Link to this post

    The scheduler does come up fine in Expressions Blend 3. Don't know if this helps.
  4. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 18 Dec 2009 Link to this post

    Hi Jeff ,

    We are still not able to reproduce your problem. The exact same scenario works fine at our side. Could you specify what version of VS2010 you are using. We are using VS2010 Beta2 and also do you have something else in the application even something simple like ScrollViewer.

    About the help issue, could you specify the error you are getting and also the version of Microsoft Document Explorer you are using. This will help in the investigation of the problem.

    In the meantime you can use our online help.



    Best wishes,
    Boyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. Jeff Cuscutis
    Jeff Cuscutis avatar
    7 posts
    Member since:
    Nov 2009

    Posted 18 Dec 2009 Link to this post

    Thanks for the help.

    My Document Explorer version is: 8.0.5.727.1826 QFE

    The error signature when it crashes (on any click to display a page):
    AppName: dexplore.exe      AppVer: 8.0.50727.1826     AppStamp:480d53d7
    ModName: msenv.dll      ModVer: 8.0.50727.1826      ModStamp:480d6b43
    fDebug: 0       Offset: 00485441


    When it restarts automatically after the error, it brings up the SQL Server 2005 Books Online (September 2007)

    My version of Visual Studio version 2010 is Beta 2 also.

    I have tracked down part of what my problem is.
    If I make a new project and add the RadScheduler, it works fine. I can close the xaml, the project, or VS2010 and reopen and it works fine until I build. After that I receive my error. As soon as I delete the bin folder for the project I can reopen the xaml successfully.

    Hope this helps.

    Thanks again for the assistance.


  6. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 19 Dec 2009 Link to this post

    Hi Jeff Cuscutis,

     I am using Document Explorer 9. So could you try to install a newer version. You can try this one. Hope it will resolve your problems. It seems strange to me that you are using VS 2010 and you are with older version of Document explorer than me as here on my machine i have only VS2008.
     About the second problem we continue with the investigation and we will make you aware of any changes of its status.

    Greetings,
    Boyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Monalisa
    Monalisa avatar
    35 posts
    Member since:
    May 2009

    Posted 21 Dec 2009 Link to this post

    Hi,

    We are getting a build error

     

    “Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.’”

     

    When we add ANY Telerik Controls to a Silverlight project’s XAML files.

     

    Please describe what could be wrong here and what is the solution.

     

    The software/settings are:

     

    VS 201 Beta 2

    Silverlight 4

    RadControls_for_Silverlight_2009_3_1208_TRIAL

     

    Thank You.

  8. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 21 Dec 2009 Link to this post

    Hi Monalisa,

    The problem seems to be that you are trying to use our Silverlight 3 assemblies with Silverlight 4 installed on your machine. In order to use RadControls with SL4 you need to download them from this location http://www.telerik.com/downloads.aspx?fileid=10057&dispkey=True .

    If you still have problems please let me know.

    Greetings,
    Boyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Jeff Cuscutis
    Jeff Cuscutis avatar
    7 posts
    Member since:
    Nov 2009

    Posted 21 Dec 2009 Link to this post

    I am leery of downloading Microsoft Document Explorer from a non Microsoft site. Is there a Microsoft download or is it part of some other package?
  10. Monalisa
    Monalisa avatar
    35 posts
    Member since:
    May 2009

    Posted 22 Dec 2009 Link to this post

    Hi Boyan,

    I downloaded RadControls with SL4 from this location http://www.telerik.com/downloads.aspx?fileid=10057&dispkey=True. But again I am getting the same error i.e. (“Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.’”) when am trying to add any control in XAML file.

    Please help

    Thank You,
    Monalisa


  11. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 23 Dec 2009 Link to this post

    Hello Monalisa,

    Is your project working with the Microsoft controls. Or you see this error only with Telerik controls?



    Regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  12. Monalisa
    Monalisa avatar
    35 posts
    Member since:
    May 2009

    Posted 23 Dec 2009 Link to this post

    Hi Valentin,

    Thanks for your reply.
    My project works fine for Microsoft Controls,Telerik controls with Asp.Net ajax but only problem for RadControls with Silverlight.

    Thank you,
    Monalisa
  13. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 23 Dec 2009 Link to this post

    Hello Monalisa,

    Check this forum post - 
    http://forums.silverlight.net/forums/t/49566.aspx

    Please let us know how it goes.

    Kind regards,
    Valentin.Stoychev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top