Please add a warning that the installation will replace .NET Framework 4.0 with 4.5

2 posts, 0 answers
  1. David
    David avatar
    13 posts
    Member since:
    Sep 2012

    Posted 06 Feb 2017 Link to this post

    My gripe with JustDecompile - Upgrading .NET Framework from 4.0 to 4.5+ is a major upgrade. Both versions do not run side-by-side. Version 4.5 actually uninstalls and replaces version 4, therefore, the decision to upgrade must be made with careful consideration. Yet nowhere on the download page or during the installation process is there any warning that this will happen. I caught it only by reading the status messages that display during the installation process. Fortunately there was no harm done to my development machine because I took a snapshot of my virtual prior to installing.

    Suggestions

    1.  Add the requirements to the download the page and to the installation welcome screen. Highlight .NET Framework 4.5 in bold.

    2. Make a user click a checkbox during the installation process that alerts the user that .NET Framework 4 will be replaced with NET Framework 4.5. If the user does not agree to this than exit the installation.

    Question

    Which is the latest version of JustDecompile that runs on .NET Framework 4

  2. Vesko
    Admin
    Vesko avatar
    124 posts

    Posted 07 Feb 2017 Link to this post

    Hello David,

    Thank you very much for sharing your feedback. Your suggestions are reasonable and will be considered.

    Just for your information you can find a list with products and prerequisites that will be installed on the second page of the Control Panel (it is not visible however). Take a look of the attachment.

    The latest version of JustDecompile that has no .Net Framework 4.5 prerequisite is 2016.1.316 (Q1 2016 SP1). This version required .Net Framework 4.0.

    Please let me know if I can assist you further.

    Regards,
    Vesko
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top