Can't type comma in filter-popup

3 posts, 0 answers
  1. haagel
    haagel avatar
    52 posts
    Member since:
    Feb 2010

    Posted 13 Jun 2011 Link to this post

    I have a RadGridView where one of the columns is of type decimal. I want to be able to filter that by decimal numbers, but it's impossible to type commas in the textboxes in the filtering popup.


    The filtering itself works fine. I've tried to apply a filter with a decimal (0.5) with code and it works: the correct rows are displayed and the rest are hidden. But when I did this the textbox in the popup displayed '0' and not '0.5'.


    Why is this and is there any way around this? Is it a bug or is it by design? Hopefully it is not by design because that would render the filtering useless in my case since all my numbers are less than 1...

  2. Dimitrina
    Dimitrina avatar
    3769 posts

    Posted 13 Jun 2011 Link to this post

    Hi haagel,

     I have tested the scenario that you have described, but unfortunately I was not able to reproduce it.
    For the testing purposes I have prepared a sample project with a column of type decimal. I have added a programmatic filtering as well. When I apply the filtering, the textbox in the filtering popup is populated correctly.

    May you please review the sample project and change it so that the problem could be reproduced? This way we could advise you appropriately.

    I am attaching the example project.

    Best wishes,
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. haagel
    haagel avatar
    52 posts
    Member since:
    Feb 2010

    Posted 14 Jun 2011 Link to this post

    It seems like this is an old bug that has been fixed.

    When I use the DLLs that we are currenty using in our project the problem occurs every time, but when I tried to switch them out for the ones in your sample project it works fine.

    Our DLLs version: 2010.3.1314.40
    Your DLLs version: 2011.1.419.35

    Guess we'll have to upgrade if we want to make this go away...
Back to Top