"you are using unsupported command line flag --disable web security" error

6 posts, 0 answers
  1. Julia
    Julia avatar
    3 posts
    Member since:
    Nov 2015

    Posted 12 Nov 2015 Link to this post

    Hi,
    I'm seeing this "you are using unsupported command line flag --disable web security" error message in Chrome (Version 46.0.2490.86 m)​, which appears to be coming from Test Studio plugins, as I don't see it when those are disabled.
    Is there a way to get rid of that error message?
    Thanks,
  2. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 12 Nov 2015 Link to this post

    Hi Julia,

    That's actually a benign warning that you can safely ignore. It is a command line parameter that Test Studio uses and was required on older versions of Chrome. We keep it in there just for backwards compatibility. The current version of Chrome just ignores the command line parameter (after showing you the warning message).

    Regards,
    Cody
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Ignatz
    Ignatz avatar
    1 posts
    Member since:
    Sep 2012

    Posted 28 Apr in reply to Cody Link to this post

    Hi there. I'm afraid I see this warning as less than benign. One of the things we do is to collect screen grabs for regression testing against earlier screen grab versions. Image comparisons all fail in Chrome because now the browser screenshots have the warning in the images, which was previously absent.

     

    Can Telerk not do something to remove this please? It's impacting our testing significantly. Thanks.

  4. Konstantin Petkov
    Admin
    Konstantin Petkov avatar
    1911 posts

    Posted 29 Apr Link to this post

    Hi Ignatz,

    Thank you for your question!

    I understand your concern and have good news to share with you. We recently discovered a solution to hide this warning and implemented the change internally. The update will be available with an internal build in the first half of May as well as the next official release scheduled to go live by the end of June, 2016.

    Please excuse us for the temporary inconvenience!

    Regards,
    Konstantin Petkov
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  5. Deepa
    Deepa avatar
    3 posts
    Member since:
    Oct 2016

    Posted 17 Nov in reply to Konstantin Petkov Link to this post

    Hi Konstantin,

    I am getting the same error while running my tests in Chrome browser - You are using an unsupported command-line flag : disable web security. I am using the latest version of Test Studio - 2016.3.928.0. Can you let me know what I need to set in TS to overcome the error?

    Thanks..

     

     

  6. Nikolay Petrov
    Admin
    Nikolay Petrov avatar
    81 posts

    Posted 21 Nov Link to this post

    Hi Deepa,

    To see this message is the natural way when using Tests Studio with Chrome. It is not an error and it is needed for the test automation. Current behavior of this alert is to be closed right after it appears.

    Please, share with us how does this disturbing your work.

    Regards,
    Nikolay Petrov
    Telerik by Progress
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top