xmlns:telerik="telerik.web.ui"

2 posts, 0 answers
  1. Carl-Johan
    Carl-Johan avatar
    22 posts
    Member since:
    May 2008

    Posted 23 Mar 2010 Link to this post

    Hi,
    First: i dont know exactly what release im using (helping afried) but it is suppost to be the latest.

    I get an wierd error when i use a radgrid.

    The problem is that when i go from code view to design view i cant see the grid. Then when i go back to code view the grad has added "xmlns:telerik="telerik.web.ui" " in the grid:
    It lookk like this:

    <

     

    telerik:RadGrid ID="RadGrid1" Width="90%" runat="server" AutoGenerateColumns="False"

     

     

    DataSourceID="ods_Main" GridLines="None" AllowFilteringByColumn="True" AllowPaging="True"

     

     

    PageSize="50" AllowSorting="True" AllowAutomaticDeletes="False" AllowAutomaticInserts="False"

     

     

    AllowAutomaticUpdates="True" xmlns:telerik="telerik.web.ui">

     

     

    <GroupingSettings CaseSensitive="false" /> <MasterTableView ClientDataKeyNames="CurrencyID" DataKeyNames="CurrencyID" DataSourceID="ods_Main"> <RowIndicatorColumn> <HeaderStyle Width="20px"></HeaderStyle> </RowIndicatorColumn> <ExpandCollapseColumn> <HeaderStyle Width="20px"></HeaderStyle> </ExpandCollapseColumn> <Columns> <telerik:GridTemplateColumn UniqueName="c_Edit" HeaderText="Ändra" AllowFiltering="false"> <HeaderStyle Wrap="false" HorizontalAlign="Center" /> <ItemStyle Wrap="false" HorizontalAlign="Center" /> <ItemTemplate> <asp:ImageButton CommandName="Edit" ID="ImageButton1" runat="server" ImageUrl="~/App_Themes/administration/Images/Edit_16.png" />

     

     

    </ItemTemplate> </telerik:GridTemplateColumn> <telerik:GridTemplateColumn UniqueName="c_Name" HeaderText="Namn" SortExpression="Name"

     

     

    DataField="Name"> <HeaderStyle Wrap="false" Width="100%" /> <ItemStyle Wrap="false" Width="100%" /> <ItemTemplate> <asp:Label ID="Label1" runat="server" Text='<%#Eval("Name")%>'></asp:Label>

     

     

    </ItemTemplate> <EditItemTemplate> <uc1:ctr_RequiredTextBox UseValidatorCallout="false" ID="CtrRequiredTextBox1" Value_String='<%#Bind("Name")%>'

     

     

    runat="server" />

     

     

    </EditItemTemplate> </telerik:GridTemplateColumn> <telerik:GridTemplateColumn UniqueName="c_Published" HeaderText="Visas" SortExpression="Published"

     

     

    DataField="Published"> <HeaderStyle Wrap="false" HorizontalAlign="Center" /> <ItemStyle Wrap="false" HorizontalAlign="Center" /> <ItemTemplate> <asp:CheckBox ID="cb_Published_Item" runat="server" Enabled="false" Checked='<%#Eval("Published")%>' />

     

     

    </ItemTemplate> <EditItemTemplate> <asp:CheckBox ID="cb_Published_Edit" runat="server" Checked='<%#Bind("Published")%>' />

     

     

    </EditItemTemplate> </telerik:GridTemplateColumn> <telerik:GridTemplateColumn UniqueName="c_DisplayOrder" HeaderText="Sorteringsordning"

     

     

    SortExpression="DisplayOrder" DataField="DisplayOrder"> <HeaderStyle Wrap="false" HorizontalAlign="Center" /> <ItemStyle Wrap="false" HorizontalAlign="Center" /> <ItemTemplate> <asp:Label ID="Label2" runat="server" Text='<%#Eval("DisplayOrder")%>'></asp:Label>

     

     

    </ItemTemplate> <EditItemTemplate> <uc2:ctr_RequiredPositiveInteger UseValidatorCallout="false" ID="ctr_RequiredPositiveInteger1"

     

     

    Value_Integer='<%#Bind("DisplayOrder")%>' runat="server" />

     

     

    </EditItemTemplate> </telerik:GridTemplateColumn> <telerik:GridTemplateColumn UniqueName="c_Rate" HeaderText="Kurs" SortExpression="Rate"

     

     

    DataField="Rate"> <HeaderStyle Wrap="false" /> <ItemStyle Wrap="false" /> <ItemTemplate> <asp:Label ID="Label3" runat="server" Text='<%#Eval("Rate")%>'></asp:Label>

     

     

    </ItemTemplate> <EditItemTemplate> <uc3:ctr_RequiredPositiveDecimal ID="ctr_RequiredPositiveDecimal1" UseValidatorCallout="false"

     

     

    Value_Decimal='<%#Bind("Rate")%>' runat="server" />

     

     

    </EditItemTemplate> </telerik:GridTemplateColumn>

     

     

    </Columns> <PagerStyle AlwaysVisible="True" /> </MasterTableView> </telerik:RadGrid>

     


    As you can see it has added "xmlns:telerik="telerik.web.ui" and messed up the code.

    Thanks,

    Kalle

  2. Carl-Johan
    Carl-Johan avatar
    22 posts
    Member since:
    May 2008

    Posted 23 Mar 2010 Link to this post

    Fixed it myself.

    I hade a 

    <%

    @ Register TagPrefix=".....

    inside the

     

    <

     

    asp:Content ID=....

    Hope this helps someone else.

     

  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top