Xap minifier shows only busy indicator

Thread is closed for posting
7 posts, 0 answers
  1. uku
    uku avatar
    57 posts
    Member since:
    Mar 2009

    Posted 24 Nov 2010 Link to this post

    Hello,

    I've used the Xap minifier the first time, or better I've tried to use.
    I've downloaded the current Q3 release and rebuild my project. Then I've used the Xap minifier, browsed for my Xap file and the only result is a never ending "Extracting..." busy indicator.

    So my question is, if I need some prerequisites. My project uses just SL4 and WCF Ria Services, so nothing special I think.

    Hopefully someone can give me a hint what the problem might be, because I think this functionality would be very helpful to decrease download size and I would really like to test it.

    Thanks

    Uwe
  2. Miro Miroslavov
    Admin
    Miro Miroslavov avatar
    588 posts

    Posted 25 Nov 2010 Link to this post

    Hello uku,

     You don't need anything special to use the Minfier, so this appears to a problem in the Minifier. Can you tell me which assemblies and controls (you can just throw me some of them), so we can create example app. with these controls and test it. 
    Thank you for the interest in the Minifier and your cooperation.
     

    Greetings,
    Miro Miroslavov
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  3. DevCraft banner
  4. Andrew
    Andrew avatar
    20 posts
    Member since:
    Mar 2010

    Posted 29 Nov 2010 Link to this post

    Hello,

    I have got the same problem. For small xap file it works fine, but for big (6MB) I spent 7 hours watching busy indicator and didn’t got any results. I’m using many controls i.e. chart, gauge, map, grid view, scheduler, context menu, menu, toolbar, tree view, media player. Attached image shows all (Telerik) assemblies I am using.

     

  5. Craig
    Craig avatar
    2 posts
    Member since:
    Oct 2010

    Posted 01 Dec 2010 Link to this post

    I'm having same issue, 5.5mb xap file using raddocking, radgrid, radexpander and radcombobox.  I'm evalauting your controls so can you let me know when its fixed so I can continue my evaluation.  Thanks.
  6. Miro Miroslavov
    Admin
    Miro Miroslavov avatar
    588 posts

    Posted 01 Dec 2010 Link to this post

    Hello Craig and Andrze,

     It appears to be a problem with the minifier - uploading bigger xaps is very time consuming and a bug in the minifier is causing to hang the UI. I've created work item for it and will do our best to fix it soon.
    Thank  you for reporting it and stay tuned for updates to it. 

    Greetings,
    Miro Miroslavov
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  7. Craig
    Craig avatar
    2 posts
    Member since:
    Oct 2010

    Posted 13 Dec 2010 Link to this post

    Hello,

    Any updates on this issue?

    Thanks,

    Craig
  8. Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 14 Dec 2010 Link to this post

    Hi Craig,

    You can view this items`s status and vote for it here. Feel free to let us know if you need more info.

    Regards,
    Petar Mladenov
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
Back to Top
DevCraft banner