Wrong Smart Complete

3 posts, 1 answers
  1. Kristian Kretschmer
    Kristian Kretschmer avatar
    9 posts
    Member since:
    Jun 2012

    Posted 27 Jun 2012 Link to this post

    Hello there,

    I am just testing out JustCode for my team and got to an really annoying point.

    while typing ( smart completion makes me a ()) of it.
    Also " goes to """.

    If i continue it works right:

    ((())) 

    I had R# installed bevore but deinstalled it.
    Also i had a lot of performance issues. To solve it i deinstalled JustCode and reset the VisualStudio settings.
    After a clean install of JustCode afterwards the performance is nice.

    I would love to see any help to solve this auto complete problem.

    Greetings from Germany
  2. Answer
    Ivan
    Admin
    Ivan avatar
    106 posts

    Posted 27 Jun 2012 Link to this post

    Hi,

    Thank you for your feedback.
    We have seen such behaviour before. It is caused by two or more extensions trying to do a smart complete.
    For example if you have JustCode and Productivity Power Tools at the same time - this could cause the issue, since both of them are trying to complete the opening bracket.
    If this is your case, I would simply advise you to turn off the smart complete feature(it's called typing assistance in JustCode) in one of the products so that they do not interfere with each other.
    If you do not have any other extensions, it would be highly appreciated if you could send me some steps to try to reproduce your issue.
    Thank you for your help!

    All the best,
    Ivan
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Kristian Kretschmer
    Kristian Kretschmer avatar
    9 posts
    Member since:
    Jun 2012

    Posted 27 Jun 2012 Link to this post

    Thank you very much for this solution!.
    I had the power tools installed and deactived it there.

    have a nice day !
Back to Top