WPF radWindow Windows 8

2 posts, 0 answers
  1. Steve
    Steve avatar
    11 posts
    Member since:
    Nov 2012

    Posted 05 Aug 2013 Link to this post


    I have a problem with a radWindow in our application in that it does not function correctly on Windows 8. The problem is that the window is displayed correctly but none of the bindings to the viewmodel (data context) work, however there are no binding errors in the output window. Also when you check the datacontext on the window it is set to the correct viewmodel its just as if the bindings are not working. The window contains a few listboxes and a radGridview and they do not display any data, but as stated no binding errors are reported. The strange thing is that the same window works perfectly on Windows 7/XP, also if you show the window from an existing modal radWindow it works as expected on Windows 8. The problem only occurs when the Window is displayed and only the main application shell window is visible which is a radRibbonWindow. I know its a bit of a long shot but has anyone got an idea on what may be causing this, with no errors or exceptions to go on its proving a real problem for us to fix?

  2. Vladi
    Vladi avatar
    743 posts

    Posted 06 Aug 2013 Link to this post

    Hello Steve,

    We are not aware of such issues with the bindings in the Windows 8 platform.

    I created and attached a sample project that shows that the bindings of a ListBox control work as expected when the RadWindow is used as a main window. Could you try to reproduce the issue in that sample project and send is back to us in a support ticket?

    Thanks in advance.

    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft R3 2016 release webinar banner
Back to Top