Windows will not load Fiddler certificate

3 posts, 0 answers
  1. Benj
    Benj avatar
    2 posts
    Member since:
    May 2015

    Posted 19 May 2015 Link to this post

    I am trying to use Fiddler to decrypt and analyze https traffic on my computer, following the instructions here (http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/DecryptHTTPS).

    When I choose "Decrypt HTTPS traffic," Fiddler prompts me to install the root certificate, and I do.  I also export the certificate to install in Firefox.

    After installation, Firefox trusts the certificate, but Chrome & Internet Explorer do not trust it, and block all navigation.  When I open the windows certificate manager (certmgr.msc), the Fiddler certificate does not appear in the Trusted Root Authority store, even after I try to manually import it.

     Any tips?

     

    Benj     

     

  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 19 May 2015 Link to this post

    Hello, Benj--

    You might try having a look at Fiddler's LOG tab to see if any error messages were recorded, but from the sound of it, the most likely explanation is that you either have installed some over-zealous security software which is silently blocking configuration changes to your computer or your PC is a corporate-managed PC and the admins have configured Group Policy to block changes to the list of trusted root certification authorities.

    How specifically did you attempt to manually add the certificate to the Trusted Store in certmgr.msc? Was a prompt shown or did it simply silently fail?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Benj
    Benj avatar
    2 posts
    Member since:
    May 2015

    Posted 20 May 2015 in reply to Eric Lawrence Link to this post

    Thanks - there was indeed a security setting and my IT team helped me resolve it.  Thanks for the pointer.     
Back to Top