Windows Authentication with IE not working

14 posts, 0 answers
  1. James
    James avatar
    11 posts
    Member since:
    Jan 2011

    Posted 06 Oct 2011 Link to this post

    Hello,

    We have TeamPulse set up using our domain login. When I try to connect to the TeamPulse server I get a prompt for a username and password. When I enter my credentials it will not log in and eventually get a "401 - Unauthorized: Access is denied due to invalid credentials." error. I do the same thing with Firefox but it logs in just fine. Anyone heard of anything like this? I want to make it work with IE.

    Thanks,
  2. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 07 Oct 2011 Link to this post

    Hello Coley,

     We've similar problems for our hosted trial and we suggest people to use ".\[username]" in IE. Another think that you can do is to add the url to teampulse in your trusted sites.

    Greetings,
    Jordan
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  3. James
    James avatar
    11 posts
    Member since:
    Jan 2011

    Posted 07 Oct 2011 Link to this post

    That is not working. I have tried adding it to my trusted sites with security as low as it can go but this ".\[username]" just tries to log in with my local pc account...
  4. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 11 Oct 2011 Link to this post

    Hi Coley,

     Do you try to add the name of the computer where is TeamPule or IP instead the domain? Similar to:
         [hostname]\username
         [ip]\username

    All the best,
    Jordan
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  5. James
    James avatar
    11 posts
    Member since:
    Jan 2011

    Posted 11 Oct 2011 Link to this post

    Yes I tried both the hostname and the IP instead of the domain and it did not work. Same error.

    Is there a reason I would want to try to log on with a local account instead of the domain account? When I log on with my domain account in Firefox it works fine. But I want it to work with IE. It seams like it has to be some setting in Internet Explorer. If I can log in with my domain credentials just fine in Firefox but not IE. I would deffinately say it's an IE browser setting of some kind. But what?
  6. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 14 Oct 2011 Link to this post

    Hi Coley,

     Can you look at this thread http://www.telerik.com/agile-project-management-tools/community/forums/teampulse/general-discussions/http-error-401-1-unauthorized.aspx?

    Kind regards,
    Jordan
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  7. James
    James avatar
    11 posts
    Member since:
    Jan 2011

    Posted 14 Oct 2011 Link to this post

    I don't see a solution in here...

    Can you give me step by step instructions on how to fix this???

    Thanks,
  8. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 14 Oct 2011 Link to this post

    Hello Coley,

     Sorry, the link that I was writing for is http://support.microsoft.com/kb/896861/en-us. Can you check if your case is the same?

    Greetings,
    Jordan
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  9. Michael
    Michael avatar
    3 posts
    Member since:
    Feb 2011

    Posted 09 Dec 2011 Link to this post

    Hi Jordan,

    We were having the same issue here, but were able to fix it by editing the authentication providers in IIS.

    In IIS7,
    1. Start the IIS Manager
    2. Select the TeamPulse web site
    3. Double click Authentication
    4. Select Windows Authentication
    5. Select Providers from the Actions menu
    6. Remove Negotiate from the list of Enabled Providers
    7. Add Negotiate:Kerberos to the List of Enabled Providers

    Hope this helps,

    Michael

  10. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 12 Dec 2011 Link to this post

    Hi Michael,

    If I understand you correct you've managed to resolve the problem. Is that true?

    Best wishes,
    Jordan
    the Telerik team
    New TeamPulse release is here!
    Want to know what’s New and how TeamPulse could help you better tight with your clients?
    Reserve a seat for the TeamPulse R3 Webinar today!
  11. Michael
    Michael avatar
    3 posts
    Member since:
    Feb 2011

    Posted 12 Dec 2011 Link to this post

    Hi Jordan,

    Yes this resolved the problem in our instance. We were working around the problem by using browsers other than internet explorer for those that had this issue, but we had to look further into it when we started developing a TeamPulse integration module for the AnkhSVN visual studio plugin and the authentication was stopping us from accessing the data service.

    Regards,

    Michael
  12. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 13 Dec 2011 Link to this post

    Hello Michael,

     I'm glad that you have resolved the issue. If you have additional question we will be happy to answer especially for any kind of development on top of TeamPulse. Have you seen our new release? We implemented forms authentication.

    Kind regards,
    Jordan
    the Telerik team
    New TeamPulse release is here!
    Want to know what’s New and how TeamPulse could help you better tight with your clients?
    Reserve a seat for the TeamPulse R3 Webinar today!
  13. Michael
    Michael avatar
    3 posts
    Member since:
    Feb 2011

    Posted 18 Dec 2011 Link to this post

    Hi Jordan,

    I have seen your new release, unfortunately while the upgrade process went well we experienced a series of issues post upgrade which meant that I had to reinstall the previous version of TeamPulse.

    I will have another attempt over the next couple of weeks when things get a bit quieter and send you more information. But the first was around authentication issues with our integration plugin. We also had other issues with the standard web client with error messages popping up on some screens.

    I do not have any more information for you at the moment as these issues were getting in the way the downgrade was performed so as to avoid data loss. If we still have issues when I try again I will send you more information.

    Also, when I reinstalled the previous version the steps outlined below did not work I had to add the Negotiate provider back in to make it work.

    Regards,

    Michael
  14. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 22 Dec 2011 Link to this post

    Hello,

    I'm sorry to hear that you had problems upgrading to our R3 release.
    We've made some breaking changes in the authentication to the oData. You need to update your app. You can learn more in our blog post here. At the end there is a link to a sample project.

    If you have other issues do not hesitate to contact us.

     

    Regards,
    Jordan
    the Telerik team
    New TeamPulse release is here!
    Want to know what’s New and how TeamPulse could help you better tight with your clients?
    Reserve a seat for the TeamPulse R3 Webinar today!
Back to Top