Why RadEditor not use in List Items?

3 posts, 0 answers
  1. alex
    alex avatar
    2 posts
    Member since:
    Jul 2010

    Posted 20 Jan 2011 Link to this post

    Hello,
      
    Today I install RadEditorMOSS_4_5_6, I can use RadEditor Web Part ,but RadEdiot not used in List Items.I still see the default editor or a simple textbox after I activate the RadEditor feature! And I had rebot the machine!
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 20 Jan 2011 Link to this post

    Hello Alex,

    The first time you activate a RadEditor feature, you must be logged as an Administrator user. This is required, because the editor needs to update the default list editing template by copying a file - from \TEMPLATE\FEATURES\RadEditorFeature\RadEditorList.ascx to \TEMPLATE\CONTROLTEMPLATES\RadEditorList.ascx.

    The file is copied by the IIS worker process, which in turn is impersonating the currently logged in user. That is why you need to be logged in as an Administrator to be able to copy the file. Once the file is copied, any user can activate/deactivate the RadEditor features. The RadEditorList.ascx file will stay until you uninstall the RadEditor for MOSS product. This means that is you upgrade to a newer version of the editor, you will need to re-activate (deactivate and then activate) the editor feature on any of the sites (only one is needed) in order for the RadEditorList.ascx file to be copied again. Again you should be logged in with an Administrator user when you activate the feature for the first time after an upgrade.



    All the best,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.

  3. alex
    alex avatar
    2 posts
    Member since:
    Jul 2010

    Posted 20 Jan 2011 Link to this post

    Thanks! I copied the file! I‘s OK!
Back to Top