Weird problem with selecting an item

8 posts, 2 answers
  1. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 03 Jun 2009 Link to this post

    Hi,

    I've used teh radcombo in the application about 100 times... the application is beeing used for weeks withoud change. Today the customer called and reported a weird behaviour:

    when clicking on the drop down arrow the lis appears, then i select an item and select the next control. When you look back to the combo, it has the value of the last item of his list, not the selected one! This is in IE7. Client repotred that FireFox had this problem also with using TAB. IE7 does not... When using a mutch, very mutch lower click tempo, the problem almost never ocoures!

    The weird thing is that it is just reported today in different browsers with no change whatsoever on the source... Also it is happening in development (VS 2008) and on 3 different servers! I've never seen this behaviour before...

    It is a big problem because the user does not alway see the change, and in the test case, is planning a train in sted of a Truck! something that could couse problems so said the client... (realy?? :-) )

    So... you get my delemma...

    Regards,

    Erik

  2. Answer
    Yana
    Admin
    Yana avatar
    4554 posts

    Posted 04 Jun 2009 Link to this post

    Hi Proovit,

    Could you please download Q1 2009 SP2 release (version 2009.1.527) and try with it? We had a similar bug which is fixed in this version.

    Kind regards,
    Yana
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 04 Jun 2009 Link to this post

    Hi Yana,

    Thank you for your reply.

    Yes, I have downloaded and tested the new version. The problem is solved there, but the manner of layout of radGrid is toaly different... so the hole application is affected.. but it will have to do.

    Thanks.
  5. Yana
    Admin
    Yana avatar
    4554 posts

    Posted 05 Jun 2009 Link to this post

    Hello Proovit,

    Which version did you use before the upgrade? All RadControls have major skin changes since Q1. 2009.

    Greetings,
    Yana
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 05 Jun 2009 Link to this post

    It was version Q3 2008. And yes, i've noticed!
    Biggest problem going to new version was the change of the sprite of the grid, witch seems unnessecerry... It has cost me 3 ours to reset the layout... even the css names are different.

    Is there a simpler way? any changes to be any time soon?!  :-|
  7. Answer
    Yana
    Admin
    Yana avatar
    4554 posts

    Posted 08 Jun 2009 Link to this post

    Hello Proovit,

    You can download all RadControls skins, which were embedded in the Q3 2008 version and have been migrated to be compatible with the Q1 2009 version from here.
    In case you're using a custom skin, you can send it to us and we'll fix it for you. 

    We have done these skinning changes for several important reasons:
    - much improved and slicker interface with the new RadControls skins
    - consistency in terms of colors, sizes, fonts, etc among all elements of RadControls
    - ability to modify/create skins through the new Visual Style Builder tool

    For more details please check this blog post.

    Best wishes,
    Yana
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  8. Erik
    Erik avatar
    314 posts
    Member since:
    Feb 2008

    Posted 09 Jun 2009 Link to this post

    Thanks Yana,

    I've have made the changes already. The only problem i encountered was the outdated documentation on the sprite, but i have found it anyway.

    Thanks for the good support!
  9. Yana
    Admin
    Yana avatar
    4554 posts

    Posted 09 Jun 2009 Link to this post

    Hi Proovit,

    You are right about the documentation, we should update it.
    If you have any other difficulties or questions, please write to us again.

    All the best,
    Yana
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017