WebView Bounce False not working

3 posts, 0 answers
  1. Sanjeev
    Sanjeev avatar
    7 posts
    Member since:
    Mar 2013

    Posted 05 Sep 2013 Link to this post

    hi i have been using icenium for sometime and have become a fan.
    So there are two questions i have to ask 
    1. Even after setting the correct  permissions in config . xml the ios webview bounce property is not getting disabled . This is my current  widget config file.
    <widget>
      <preference name="AllowInlineMediaPlayback" value="false" />
      <preference name="AutoHideSplashScreen" value="true" />
      <preference name="BackupWebStorage" value="cloud" />
      <preference name="DisallowOverscroll" value="true" />
      <preference name="EnableLocation" value="false" /><!-- DEPRECATED -->
      <preference name="EnableViewportScale" value="false" />
      <preference name="FadeSplashScreen" value="true" />
      <preference name="FadeSplashScreenDuration" value=".25" />
      <preference name="HideKeyboardFormAccessoryBar" value="false" />
      <preference name="KeyboardDisplayRequiresUserAction" value="true" />
      <preference name="KeyboardShrinksView" value="false" />
      <preference name="MediaPlaybackRequiresUserAction" value="false" />
      <preference name="ShowSplashScreenSpinner" value="true" />
      <preference name="SuppressesIncrementalRendering" value="false" />
      <preference name="TopActivityIndicator" value="gray" />
      <preference name="UIWebViewBounce" value="false" /> 
      <preference name="webviewbounce" value="false" />
     So as you can see i have set all the attributes correctly but it doesn't seem to  work.
     2. My second question is that i have the same app running on debug phase on both android and ios how is that the app performs super smooth in ios and performs very poor in android , is there a way where i can set the required memory to be allocated for the application to run smoothly in android , may be a java script that could initiallize higher memory for the application.

    Answers will be appreciated 
    Thanks 
    Sanjeev

  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 10 Sep 2013 Link to this post

    Thank you for the kind words Sanjeev, much appreciated!

    As for your questions:
    1. The property has been renamed, so if you're using Cordova 2.7, you should use  DisallowOverscroll property instead. However since the default value of this property is 'false', you do not have to set anything as it would behave as you expect. However this behavior takes effect only in a native build of the app (i.e you have to use Apple provision) - you won't be able to test this in Icenium Ion.
    2. Fragmentation of Android devices has been and is still a major problem as there are various devices that run modified versions of Android and have different hardware capabilities. So for Android, performance is pretty subjective as it depends on the device hardware capabilities and Android version being run.

      First thing that comes to mind is to try changing the Hardware Acceleration option in Properties/Android. On some devices turning it on speeds things up, but on some slows them down. You can experiment to disable Hardware Acceleration following these steps:
      • Device Settings > Developer options > Force GPU rendering: (unchecked)
      • In Icenium > Project Properties > Android > Hardware Acceleration: Off
      • Delete application from device and redeploy

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.

  3. Sanjeev
    Sanjeev avatar
    7 posts
    Member since:
    Mar 2013

    Posted 10 Sep 2013 Link to this post

    Hey Steve, 
    Thanks your help is much appreciated. But the application still lags on android , i am thinking may be reducing the css 3 animations might fasten up the app.
Back to Top